08-06-09 11:05 PM
38 12
tools
  1. sixload's Avatar
    Hey guys

    I'm having a recurring issue on my bold - being that it simply will not stay connected to my home wifi. I have tried several things along the way to fix it, including: deleting my wifi profile on the phone and setting it up again, numerous battery pulls (and keyed resets), and have rebooted my home wifi router several times.

    Nothing seems to have made a difference yet. The problem is that upon establishing the connection to the wifi signal (and saving the profile on the phone), the little "wifi" indicator does appear and illuminates after a few seconds (which means it is connected, apparently), but then after a minute or so always fades to grey, apparently meaning "disconnected." We have several other computers in the house, all running on the same wifi signal, and none of them seem to have a problem.

    Guys I would really, really appreciate any help you may be able to give me on this one, as this problem is extremely frustrating and unfortunately will mean the phone going back to the shop if it can't be fixed, as I don't really need a Blackberry just to make/receive calls and use a 3g network.

    Cheers everybody, hope you can help
    04-06-09 12:14 AM
  2. okgrjba's Avatar
    what OS are you on? when i was still on the stock .167, i had issues, but i have since been on .210 and now, .237 and it NEVER loses connectivity.

    Hey guys

    I'm having a recurring issue on my bold - being that it simply will not stay connected to my home wifi. I have tried several things along the way to fix it, including: deleting my wifi profile on the phone and setting it up again, numerous battery pulls (and keyed resets), and have rebooted my home wifi router several times.

    Nothing seems to have made a difference yet. The problem is that upon establishing the connection to the wifi signal (and saving the profile on the phone), the little "wifi" indicator does appear and illuminates after a few seconds (which means it is connected, apparently), but then after a minute or so always fades to grey, apparently meaning "disconnected." We have several other computers in the house, all running on the same wifi signal, and none of them seem to have a problem.

    Guys I would really, really appreciate any help you may be able to give me on this one, as this problem is extremely frustrating and unfortunately will mean the phone going back to the shop if it can't be fixed, as I don't really need a Blackberry just to make/receive calls and use a 3g network.

    Cheers everybody, hope you can help
    04-06-09 12:25 AM
  3. jhamilton3#CB's Avatar
    Works great for me.. sorry for your troubles.
    04-06-09 12:30 AM
  4. dictoresno's Avatar
    im on .167 and used wifi this morning for the first time to browse and didnt have any connection problems. i wonder if its the handset or possibly interference from something.
    04-06-09 12:33 AM
  5. papped's Avatar
    I have 3 different connection points with 3 different routers and haven't had a single issue on multiple OSes. But the first question is what OS are you running.
    04-06-09 12:38 AM
  6. tag824's Avatar
    First off I absolutely recommend you update your phone if at all possible to .247. But that being said here's what else you can do.

    Check if you're getting a Local IP Address, that you see a "Gateway Address:" and that you are assigned a "Primary DNS:" server by going to Wi-Fi Options and from the menu Wi-Fi Tools, Wi-Fi Diagnostics... now go to Options and change the "Display Mode:" to Advanced. You may be connected but if you don't have an IP address it won't pass any traffic and if you don't have a DNS server assigned name look up will not work. If you don't see an IP then it may be a DHCP issue, which is the service that assigns you an IP address. If you see that you do have an IP try pining your "Wi-Fi Gateway" to confirm connectivity and also something on your network by going to Wi-Fi Tools, Ping. Just make sure whatever you ping on your network does not have a firewall turned on.

    Another thing I strongly recommend is to update the firmware on your wireless Access Point to the latest version.
    04-06-09 12:54 AM
  7. avmsam's Avatar
    try doing power cycle on ur router.

    try deleting the wifi profile on ur bold and starting over.

    try resetting your router and re setting it up

    i've seen people have troubles with mobile devices, blackberries and others with specific router models.

    what router do u have?
    04-06-09 01:16 AM
  8. nibs13's Avatar
    I had a huge improvement with connection time and reliability in general over wifi once I upgraded to .247.
    I think that should be your first step

    Posted from my CrackBerry at wapforums.crackberry.com
    04-06-09 01:19 AM
  9. sixload's Avatar
    Wow. Guys, thanks so much for the replies! And here I was thinking "Oh boy, where the **** am I gonna find help for this thing???..." lol.

    Well, in repsonse to a few questions:

    1. My software is version 4.6.0.247 (Platform 4.0.0.206). I think this is the most recent OS, I upgraded it about a week ago and this is the OS I now have.
    Does this sound correct?

    2. I have deleted my home wi-fi profile on the handset as well as reboot my
    router (and re-established the connection on the handset) several times,

    To avmsam: the router I'm running is a Netgear WNR2000. Have you heard of any known problems concerning using wi-fi on blackberry bolds through this model of router?

    To tag824: Thanks so much for that info, I was wondering whereabouts on the handset I could find all the wi-fi statistics. Some success with what you mentioned, however:


    I can now connect and maintain connectivity, until I start to browse any web-pages. As long as I don't browse, it seems to stay connected just fine.
    So, some improvment, but still a little way to go. Anyone have any ideas as to what might now be causing this browsing problem, and possible ways to eliminate it? Thanks so much once again guys,
    04-06-09 05:52 AM
  10. NewOrleans7's Avatar
    I used to have the same problem you're having with my linksys router. It never wanted to stay connected. I fixed it by upgrading the router's firmware. See if you have the latest firmware for your router and if not then get it and it might start working normally.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-06-09 06:50 AM
  11. mgumbrell's Avatar
    When I go to WiFi Diagnostics - Advanced, I have no IP Address assigned.

    How do I change it so I do.
    How do I find out what OS I am using.

    From the answers given I hope that I can fix my WiFi issue.

    Regards, Matt
    04-06-09 07:29 AM
  12. 701's Avatar
    Do you have a BIS connection on your phone? I had the same problem over the weekend after updating the sw to .247 (the wifi icon was grey) but I noticed I had no BIS connection. I resent the service books, my BIS connection was updated and now the wifi icon is full,no problem.
    Just a thought...there are so many issues...
    04-06-09 08:22 AM
  13. bt224's Avatar
    try doing power cycle on ur router.

    try deleting the wifi profile on ur bold and starting over.

    try resetting your router and re setting it up

    i've seen people have troubles with mobile devices, blackberries and others with specific router models.

    what router do u have?
    Best answer on this thread. Do not upgrade the OS over this. As unlikely and illogical as it seems, I would bet it's a router issue. I'm all for security, but I think RIM has overreached a bit.
    04-06-09 08:30 AM
  14. dwigbej's Avatar
    FYI the moment I reset my router, my wifi worked flawlessly... It's wierd but it worked...
    04-06-09 08:52 AM
  15. taddley's Avatar
    I have 5 different network profiles set up for different routers in different locations using NetGear, Linksys, and a couple of others.

    The only problem I experienced was the first profile I set up. I used the "user defined" password instead of the actual hexidecimal password for the router and experienced exactly what you've described. Once I keyed in the actual hex password, all has been well.

    This is a wild guess sixload ... but, hope it helps.
    04-06-09 09:03 AM
  16. joonbugg's Avatar
    I used to have lots of problems with .167 and .185 where my wifi icon would disappear altogether. Not go dim grey, but it would be gone. Would always have to resend service books, battery pulls, etc. I have been running .237 for about a month now, and havent had one wifi issue yet. YET!!! (fingers crossed).
    04-06-09 11:26 AM
  17. Abear's Avatar
    I used to have problems, but I just did a battery pull and it worked. Not sure what was wrong. I also use it at work and it works fine.
    04-06-09 02:01 PM
  18. tag824's Avatar
    ...
    To tag824: Thanks so much for that info, I was wondering whereabouts on the handset I could find all the wi-fi statistics. Some success with what you mentioned, however:

    I can now connect and maintain connectivity, until I start to browse any web-pages. As long as I don't browse, it seems to stay connected just fine.
    So, some improvment, but still a little way to go. Anyone have any ideas as to what might now be causing this browsing problem, and possible ways to eliminate it? Thanks so much once again guys,
    sixload,

    Go to Wi-Fi Options and then highlight your network. From the menu choose Network Details. Take a look at signal strength, the lower the -dBm level the better. Devices such as cordless phones and microwaves can causing excessive noise levels and make your phone cut out when it starts sending traffic. Try to go to a web page that takes a long time to load up and then go back to the Network Details and see if your -dBm's get higher. This would point to interference from other devices.

    Think of your wireless devices as bulb that is emitting light. The farther away you are the dimmer the light. Now think of several other sources of light around your single bulb. If they too are all emitting a lot of light it makes it hard to distinguish or filter the other noise when you are at a distance.

    Since you have an IP and the latest OS for your phone only two things remain that you can do to improve your connectivity. Like I stated before upgrade your Wireless Access Point's firmware. The other is to eliminate any devices that could be causing interference. I assume your wireless network is 802.11b/g which is common for home use. This falls into the range of the 2.4 GHz band. If you have phones that are 2.4 GHz try unplugging them and doing some tests. Also be aware, your neighbors may have devices too.
    04-06-09 04:08 PM
  19. oracle107's Avatar
    I was having many problems on .162 with an older wireless B Linksys router. I know I could have tried updating the firmware but I wanted a new router anyways so I got a new Linksys WRT160N wireless N router. After that it worked flawlessly. It may have dropped 2-3 times in 4 months. Using WPA2 security.

    However it was laggy at times with opera mini, but not sure what the problem was. I upgraded to .247 and now it is just perfect! Browsing speeds are really fast and it hasnt dropped but its only been a day.
    04-06-09 05:03 PM
  20. ka3yan#CB's Avatar
    My issue is, I believe, mostly about the range. I realize that the antenna in the bold must be rather small, but I have extremely poor range. It seems that unless I'm in the same room as the router, I barely have any signal at all. I'm using an ASUS WL-500W Wireless N (Draft) router with the latest firmware.

    Does anyone know what the best channel to use is? I put mine on channel 7 to avoid conflict with my neighbors who use channel 6. I figured that the closest I could get to the middle of the band the better, but I don't know what frequency the Bold's antenna is tuned to (best freq with lowest VSWR).

    BTW, I am also experiencing the gray WIFI logo. I'm just assuming that my problem is related to poor signal strength and not service book, etc.
    04-06-09 05:32 PM
  21. webhead's Avatar
    I've had great WIFI interaction from my Bold and my LAN since .167 to .247 on mine.
    04-06-09 05:44 PM
  22. oracle107's Avatar
    My issue is, I believe, mostly about the range. I realize that the antenna in the bold must be rather small, but I have extremely poor range. It seems that unless I'm in the same room as the router, I barely have any signal at all. I'm using an ASUS WL-500W Wireless N (Draft) router with the latest firmware.

    Does anyone know what the best channel to use is? I put mine on channel 7 to avoid conflict with my neighbors who use channel 6. I figured that the closest I could get to the middle of the band the better, but I don't know what frequency the Bold's antenna is tuned to (best freq with lowest VSWR).

    BTW, I am also experiencing the gray WIFI logo. I'm just assuming that my problem is related to poor signal strength and not service book, etc.
    I don't think this range issue has anything to do with your BOLD especially if you are having problems in the next room. I think you should rule that out and dig deeper. Maybe even try another router.

    I have a perfectly good connection in my backyard 60 feet from the router that's on the 3rd floor and there is plenty of interference in between from other electronics/neighbors/walls/trees etc...
    04-06-09 05:51 PM
  23. anon(153966)'s Avatar
    As a test, add the MAC address for your BOLD to your router, and see what happens...

    Posted from my CrackBerry at wapforums.crackberry.com
    04-06-09 05:58 PM
  24. ka3yan#CB's Avatar
    As a test, add the MAC address for your BOLD to your router, and see what happens...

    Posted from my CrackBerry at wapforums.crackberry.com
    Good thought, that was actually going to be my next move. I am going to work on this systematically I believe. I'll start there, then try different channels, then maybe try with no wireless security, etc. There's a bunch I can do. Unfortunately I do not trust the custom firmware (dd-wrt) for the ASUS router. I have heard MANY cases of this bricking the router. I'm not totally happy with the ASUS router, but I don't have the cash at the moment to drop on a new one. I will definitely be going back to the Linksys WRT-54G as soon as possible. Great router for custom (and fully customizable) firmware.

    I appreciate all the feedback! As soon as I get home I'll play around and write back if I make any headway.
    04-06-09 06:44 PM
  25. tag824's Avatar
    Unless you are filtering who can connect to the AP by MAC address it's not going to make any difference if you add it or not. If you are connected to the AP and are passing traffic then you are connected. Your issue with range is something else.
    04-06-09 07:19 PM
38 12
LINK TO POST COPIED TO CLIPBOARD