1. manicss01's Avatar
    I just got a new blackberry 9000, and it was on t mobile.

    I wanted to use it on O2, so unlocked it and rang O2.

    They said i needed to download the O2 firmware.

    So i did, and i began updating the firmware - unfortunately, during step 4/5 (waiitng for initialisation), the whole program stalled!

    nothing happened, nothing responded, but i didnt want to disconnect, so i left it in there for 4 hours.

    Finally i disconnected, and now the BB doesnt turn on. it goes the white screen with the small clock in the middle. its not being found by the desktop manager at all. WHAT DO I DO?!

    please tell me my bberry isnt bricked. im so worried.

    please can somebody help me fix this...
    08-11-09 08:47 PM
  2. bt224's Avatar
    Well, they lied, you can use whatever firmware you want.

    Don't panic, you can fix this.

    Try this.
    http://forums.crackberry.com/f3/how-...ckberry-32322/

    Everything you'll need is on the site in my sig. The guy did a great job pulling everything into one place.
    08-11-09 08:52 PM
  3. anon(51467)'s Avatar
    Did you try catching the BB during the first part of boot up using the loader.exe from "C:\Program Files\Common Files\Research In Motion\AppLoader\" ?

    This is not a time to use Desktop Manager.
    08-11-09 08:53 PM
  4. manicss01's Avatar
    Thank you so much for the replies

    For some reason god decided to love me, and upon trying and trying of trying to get my blackberry picked up - on the 28th time or something, it was!

    the firmware upgrade had all been done and it was all very weird.

    Thanks for your help - i will stay clear from touching my firmware, especially seen as i was using VMWare on a mac - i have a feeling that has something to do with it.

    THANKS AGAIN

    \thread
    08-11-09 09:04 PM
  5. knicksfan1025's Avatar
    How did you get a bold on t-mobile without it being unlocked in the first place?

    Posted from my CrackBerry at wapforums.crackberry.com
    08-11-09 11:26 PM
  6. pinoi's Avatar
    How did you get a bold on t-mobile without it being unlocked in the first place?

    Posted from my CrackBerry at wapforums.crackberry.com
    He got it through Tmobile europe not Tmobile USA...

    Posted from my CrackBerry at wapforums.crackberry.com
    08-12-09 01:30 AM
LINK TO POST COPIED TO CLIPBOARD