1. andyjonesx's Avatar
    I am trying to unlock my Bold 9700 (Telus). I do the following steps:

    1) Go to Advanced options
    2) Go to SIM Card
    3) Type 'mepd', which shows the following
    - Sim Disabled
    - Network Dsiabled
    - Network Subset Disabled
    - Service Provider Active
    - Corporate Disabled

    Now, when I try and type 'mep2' nothing happens. I have tried [M, E, P, ALT+E], [ALT + M, E, P, E] and still nothing shows.

    I have tried disabling all connections and repeating the above. I have also tried putting in another sim card and trying. When I put in another sim card and boot up the phone it says do I want to enter an unlock code. If I press 'yes', it goes to the normal menu.

    I've searched all over the internet and have found a few people with the same problem, but the thread never gets resolved. I have tried ever suggestion I have seen in those threads (which is just the above).

    Can anyone help me please?
    09-23-11 08:11 AM
  2. freethisberrydotcom's Avatar
    The 9700 from Telus is locked with a mep4 ... type mep + alt + then 4
    09-23-11 09:03 AM
  3. andyjonesx's Avatar
    That's brilliant thanks. Solved it!
    09-23-11 09:17 AM
  4. freethisberrydotcom's Avatar
    Bell and Telus lock theirs with mep4 aka service provider security with certain devices.
    09-23-11 09:31 AM
  5. blackberry-unlocking710's Avatar
    When you unlocking your Blackberry you need to use the right input to enter the right unlock code...

    - Sim Disabled
    - Network Dsiabled < MEP2 unlock code
    - Network Subset Disabled
    - Service Provider Active <MEP 4 unlock code
    - Corporate Disabled

    Just posting it for the other users, i see that you have solved this issue - enjoy your unlocked Blackberry
    09-26-11 10:53 AM
  6. rmusical's Avatar
    hi everybody

    hel me for the same issue for bb tour 9630 reliance cdma.sim disabled and network blocked,
    after typing mep2 or mep4 doesnot show anythin ..

    pls ive any solution

    10-06-11 11:35 AM
  7. mic2183's Avatar
    Hi... I am having the same problem with trying to enter mep2 and nothing happens....

    NETWORK....... Active.

    Can I get some assistance?
    10-03-12 08:24 AM
  8. mic2183's Avatar
    the phone i am trying to unlock is bb9320
    10-03-12 08:24 AM
  9. lemmonnadeboy's Avatar
    i have a blackberry bold 9930 when i type mep2 nothing pops up....i need help with what to do!! please help!
    11-24-12 07:05 AM
  10. Cyba Cowboy's Avatar
    Where are you typing that, and what's it supposed to do?

    I'll try it on my BlackBerry Curve 9320...

    Sent from my BlackBerry Curve 9320, using Tapatalk.
    11-24-12 07:23 AM
  11. saudadeii's Avatar
    i have a blackberry bold 9930 when i type mep2 nothing pops up....i need help with what to do!! please help!
    You're in the wrong forum. This is the 9000 Bold. The 9930 runs a differrent OS. You should look in the 9930 forum here:

    BlackBerry Bold 9930/9900 - BlackBerry Forums at CrackBerry.com
    11-24-12 09:48 AM
  12. Chimwemwe Munthali's Avatar
    I want to unlock my bb 9320, I have an unlock code for MEP2 but what my bb is requesting for is MEP so the code is not working, my IMEI is 354872051184467. kindly help
    06-27-13 04:25 AM
  13. shakur moulton's Avatar
    hi nothing still shows i wonder why i have Blackberry 8520
    03-19-14 10:04 PM