1. SpaceGeek's Avatar
    Everything has been working just fine on this phone for months. I suddenly had an exception error while adding a calendar entry. When the phone came back to life, the icons for SMS messages and my email account are missing . I tried adding the email back, but the phone says I am already setup. One other observation is that there now appears a black square where the phone setup icon used to be.

    Is there any way I can get them back?
    08-07-09 03:42 PM
  2. Pilot Prop's Avatar
    I had this same issue, and it comes back from time to time....all I did was 2 battery pulls and all was well...try that and see what happens...good luck

    Posted from my CrackBerry at wapforums.crackberry.com
    08-07-09 03:57 PM
  3. crackzilla's Avatar
    Do a complete wipe and re-install OS. Search the forums for step-by-step instructions.

    I had one before and it cleared up after a few hours no icons lost luckily.

    GOOD LUCK!!!
    08-07-09 04:05 PM
  4. nh.bbold's Avatar
    I had this exact same problem with "fatal exception" errors and various other "java" errors. It finally came down to me actually using my warranty and getting a new Bold.

    But for the time being (and if you can't use your warranty), to make it work properly I just kept doing battery pulls until it loaded with my normal settings and icons.
    08-07-09 04:16 PM
  5. mark-d's Avatar
    I had this issue with my Bold about a month after I got it. Tried to re-set up the emails but they were already on the BIS site so I couldn't.

    Pulled the battery, Bold re-started but on the other default theme on the device. When I put it back to the theme I was using previously everything was fine and has worked fine since.
    08-07-09 04:22 PM
  6. bt224's Avatar
    Battery pull, then resend service books just in case it did effect your e-mail setup.
    08-07-09 05:20 PM
  7. mysti.que's Avatar
    I had this happening frequently. I fixed it by doing a downgrade to It hasn't recurred..

    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    08-07-09 05:31 PM
  8. thempigs's Avatar
    i lost my weather berry icon and some others i think i hid them how do i bring them back please help
    08-07-09 06:16 PM