Built for Business - Learn more about BlackBerry KEY2

View Poll Results: Canadians: Does your Bold have all the problems that are alleged!??!!

Voters
29. You may not vote on this poll
  • No. My Bold is working just as it should minus a few errors here and there

    26 89.66%
  • My Bold works fine, but has problems quite a bit, but I'm going to stick it out with it

    2 6.90%
  • Yes. I want to throw my Bold against the wall, I'm so mad with this POS.

    1 3.45%
  1. Crunch's Avatar
    ...here:

    Orange pulling Bolds to fix software issues, AT&T smiles - Engadget Mobile

    ...and here:

    Orange drops the Blackberry Bold due to quality issues : Boy Genius Report

    How does your Bold perform on Rogers?? I'm calling BS with this Orange withdrawing the Bold from their line-up because of RIM's alleged "inadequate" firmware, etc. It may be true on Orange's network, which is why I'd like to know about our friends to the North.

    Thanks for any feedback.
    10-10-08 02:54 PM
  2. aeldes1's Avatar
    I've been using this device for a WHILE now, with no problems whatsoever regarding the network. Never had a dropped called. Very rarely does it go onto the edge mode instead of 3G. No random restarts either (well, very rarely actually). There are some bugs with the browser, and media scanning takes a while (but that's only when the device loads up).
    10-10-08 03:00 PM
  3. jceezy's Avatar
    nope, my bold works perfect with .162. originally had "push" problems with .125 but since upgrading, everything is all peachy. browser works fast, no drops between edge and 3g, no random restarts. only issue is with youtube, but thats not roger's fault. been reading and a lot has been complaining about it.
    10-10-08 03:59 PM
  4. PhuFighter's Avatar
    Heh. When I got the Bold, the OTB firmware sucked. I was pretty close to returning it. I'm glad I didn't now since the .162 firmware is awesome. This is pretty much as good as I can expect now.. And, yes, I am happy. Very happy.
    10-10-08 04:13 PM
  5. sito's Avatar
    my bold works perfectly with new OS. there is no glitch. I might be lucky person.
    10-10-08 04:25 PM
  6. Fabmaclover's Avatar
    no issue regarding , drop calls, networking or anything else so far .. finger crossed
    10-10-08 04:29 PM
  7. infomax's Avatar
    So far so good.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-10-08 04:45 PM
  8. kingbernie06511's Avatar
    No problem whatsoever. The browser of the original firmware sucked, but now everything is cool...
    10-10-08 04:58 PM
  9. Cocotaso's Avatar
    RIM is meant for ROGERS!

    You should of had an option

    No. My bold is working just as it should. Perfectly fine.

    Closest to that option was :
    No. My Bold is working just as it should minus a few errors here and there
    10-10-08 05:35 PM
  10. aeldes1's Avatar
    RIM is meant for ROGERS!

    You should of had an option

    No. My bold is working just as it should. Perfectly fine.

    Closest to that option was :
    No. My Bold is working just as it should minus a few errors here and there
    Well, yes of course. RIM does most of their beta testing on the Rogers network. But soon Bell and Telus will also have HSDPA!!! YAY
    10-10-08 05:38 PM
  11. Crunch's Avatar
    Looks like Microsoft is interested in acquiring RIM when the shares drop to $40/share. RIM has been hurting, and the company's net worth has been plummeting. I like Windows Mobile a LOT, but I love the Blackberry OS, too.

    Do we have anyone from Australia or Europe who can comment on their Bold's working, or not working?

    You guys from Canada seem to be pretty happy with the quality of it, which is good!
    10-10-08 06:22 PM
  12. Iptorrentin's Avatar
    I've had my 9000 for about a month now & I love it!!!!!! (I believe my girlfriend is getting a little jealous!)

    I haven't really had any problems with it at all. (knock knock)
    10-10-08 07:54 PM
  13. cspec's Avatar
    With new OS, the Bold is impeccable...

    ...almost.
    10-10-08 07:56 PM
  14. vt3c's Avatar
    mine works fine, i do find some lag in the browser like trying to run crackberry on it takes a little while to load, but .162 is a very big improvement then the OTB OS
    10-10-08 08:03 PM
  15. Crunch's Avatar
    NICE...awesome!

    So...WHAT SEEMS TO BE THE PROBLEM??????? With a release on AT&T, that is??? Canada has it, Germany has it (on both T-Mobile AND Vodafone!), Australia has it...So this Orange carrier is able to give the Bold a bad name???

    I played around with one in a T-Mo store in Germany, and it just looks fantastic. The screen, the keyboard...ahhhh...Gorgeous feel with the leather back.

    Well, my Palm Treo Pro had BETTER arrive tomorrow! This WILL hold me over. I hate my iPhone 3G. Just jailbroke OS 2.1. So now it's waiting for some sucker who's going to pay me $700-$800.

    AAAAAAAAAAAAAAAHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH... ok, it's time for a XANAX! A 2mg one!

    The polls are in: Over 82% LOVE their Bolds, and almost 95% either LOVE IT, or at least LIKE it.
    Last edited by Crunch; 10-10-08 at 08:08 PM. Reason: I love AT&T, but please, come on now!
    10-10-08 08:04 PM
  16. RidiculousHat's Avatar
    the first delays were because the phone wasn't ready. the initial os'es, which i would say are basically anything before .147, were crap. if i recall correctly, the initial os was .092, and that was basically unusable. .126 improved but still wasn't really acceptable. now .162 is the os that the phone should've had to begin with.

    however, at&t is still experiencing problems of its own-- their network can't support both the iphone and the bold. ****, it can barely support the iphone by itself. they go into this more on the front page, but suffice it to say that everyone has egg on their faces. at&t's network is to blame, but RIM caused the hype and resulting dissatisfaction among blackberry faithful by announcing the phone too early and pushing beta software out everywhere else worldwide.
    10-10-08 09:33 PM
  17. akide's Avatar
    had a few dropped calls, and also some issues with 3G not working properly until i rebooted/reset my phone.
    10-10-08 09:45 PM
  18. joeybee's Avatar
    On my second Bold...First one got stuck on clock of death and extreme battery drain. Rogers sent me a refurb next day and its been working fine. On the first one I had quite a few browser issues on .126 but once i upgraded to .147 and .162 its been much better.
    10-10-08 09:50 PM
  19. Crunch's Avatar
    KEEP VOTING folks...Ohhh Ca-naaa-daaa...You guys have the best device!!!!!!!!!!!! I betcha, had I picked up one up in Krautland or ordered one off ebay, I'd be JUUUUUUUST fine! ATT, put out...I mean put it out!
    10-10-08 09:56 PM
LINK TO POST COPIED TO CLIPBOARD