1. lfarmer's Avatar
    BB maps was working fine. I went to use it today and the icon was gone! Check applications list, yup it was there alright, checked DM and it also says that it was loaded. Deleted it re-installed nope no icon. Checked on Blackberry web site, it says Blackberry Maps are not supported by AT&T. Since when, it was working? If I unlock my Bold(AT&T) will it work? What right does a cellular provider have to disable the entire app? Even verizon only cripple GPS until recently.
    03-21-09 05:59 PM
  2. bineon's Avatar
    Tons of threads already abt this. Same thing happened to me. ATT has every right to disable the app, you signed the contract. Try using a different theme perhaps.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-09 06:06 PM
  3. lfarmer's Avatar
    Tons of threads already abt this. Same thing happened to me. ATT has every right to disable the app, you signed the contract. Try using a different theme perhaps.

    Posted from my CrackBerry at wapforums.crackberry.com
    Already tried a different theme to no avail.
    03-21-09 06:08 PM
  4. skyjackal's Avatar
    If you have a backup from a point prior to losing the icon, do a restore and it will come back. Happened to me as well. BTW, sending service books to your phone will delete the icon again (happened to me 2x) in which case you'll have to do another restore. So try not to do it unless necessary.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-09 06:12 PM
  5. Dimietriev's Avatar
    This happened to me aswell today. I deleted my gmail account, re-added and resent service books for the 2.6 BIS upgrade. And now poof, can't get the icon back no matter what.
    03-21-09 06:26 PM
  6. lfarmer's Avatar
    If you have a backup from a point prior to losing the icon, do a restore and it will come back. Happened to me as well. BTW, sending service books to your phone will delete the icon again (happened to me 2x) in which case you'll have to do another restore. So try not to do it unless necessary.

    Posted from my CrackBerry at wapforums.crackberry.com
    Restored service books from an old Backup. Problem fixed, thanks. I don't know if this will help others with the same issue but the service books were restored from a backup dated 2-14-09.
    03-21-09 06:34 PM
  7. Dimietriev's Avatar
    Is there a way to only restore the service books, and not all my old crap? or am i just shooting for the moon.
    03-21-09 06:40 PM
  8. lfarmer's Avatar
    Is there a way to only restore the service books, and not all my old crap? or am i just shooting for the moon.
    Yes, choose advanced from the restore menu. Then select a dated backup. Scroll to service books a click the arrow to add to device. This will restore only the service books.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-09 06:46 PM
  9. kwongsauce's Avatar
    Use Google Maps. It's pretty good.
    03-21-09 07:02 PM
  10. Dimietriev's Avatar
    I know google maps is good, I have it too.
    It is a matter of principal, I should have the choice to use bbmaps if i want to.
    03-21-09 07:07 PM
  11. LondoJowo's Avatar
    Here's the 2 replies I've received from AT&T on BB Maps.

    AT&T does not provide technical support for BlackBerry Maps. AT&T makes no warranties, express, implied or statutory, as to the content within this solution; such content is provided "as is" and with all faults, and your use of the content is at your own risk.
    I have reviewed your inquiry. The service books sent to your phone,
    causing the Blackberry Maps application to be disabled, were sent from
    Research in Motion (the manufacturer of Blackberry devices), not from
    AT&T.
    03-21-09 07:14 PM
  12. Mamaluka's Avatar
    No bb maps? That's it! Dealbreaker, I'm going back to verizon.
    Heh just messin round. And bored

    Posted from my CrackBerry at wapforums.crackberry.com
    03-21-09 07:32 PM
  13. twodumbdogs's Avatar
    Weird. I have BB MAps on my Bold. I have resent service books to it in the last month and the icon is still there and it still works.
    03-22-09 12:27 PM
  14. giantfan30's Avatar
    Weird. I have BB MAps on my Bold. I have resent service books to it in the last month and the icon is still there and it still works.
    oh you have huh? do like i did and go resend service books today...poof its gone....
    i'm on an unlocked Rogers Bold on the ATT network..guess that doesnt matter anymore..if you have an ATT SIM card they are blocking BB maps..they being RIM
    03-22-09 01:04 PM
  15. LondoJowo's Avatar
    Weird. I have BB MAps on my Bold. I have resent service books to it in the last month and the icon is still there and it still works.
    If you haven't resent your service books since March 13th................don't as it will disable BB Maps. This will occur on unbranded Bold's that use AT&T as well.
    03-22-09 01:07 PM
  16. 3G.BoldBerry's Avatar
    Actually its not rim or att, if rim is not giving you the ability to dl that's different just load it from DM it should be there. The same thing
    Happen to me when I added some apps, its there but I can't see the icon. Check your application list to make sure
    Its there and try again if you use some kind of navigation thing choose bb maps it will open but
    Its not gone its just hidden and that has nothing to do with att I bin using maps for monts with
    updates as well good luck all.

    Posted from my CrackBerry at wapforums.crackberry.com
    03-22-09 02:15 PM
  17. LondoJowo's Avatar
    When you try to launch BB Maps, an error message states that Blackberry Maps is disabled.
    03-22-09 04:01 PM
  18. KJNaJ's Avatar
    I have a Rogers Bold and using it on AT&T, and the BB Maps icon disappeared from my phone as well.

    I hardly used BB Maps anyway, used google maps instead.
    03-24-09 11:33 PM
  19. pinoi's Avatar
    So I take it we should delete it from our phones then?

    Posted from my CrackBerry at wapforums.crackberry.com
    03-25-09 03:27 AM
  20. TunaRollz's Avatar
    that's weak...just hit me today as well. anyone try reinstalling through the latest DM? How do you resend service books anyway?
    04-01-09 11:53 PM
LINK TO POST COPIED TO CLIPBOARD