1. Billch79's Avatar
    Hoping someone can help me here. I have a BB bold, which is great, I'm very happy with it overall. The only problem I have is that for some reason, when I sync it with my bluetooth car kit (Nokia CK-7W) it creates an echo for the person on the other end. It's quite annoying for them although I can't hear it at all. I had the same problem with my BB 8100 pearl. It seems to be some inherent incompatibility between the BB and the Nokia car kit.

    However, I have tried numerous other phones with the car kit, including iphone, sony ericsson, nokia and all work without a problem, its only having an issue with the BB. Anyone had a similar experience and managed to work it out??
    02-03-09 02:26 AM
  2. TheHangingJudge's Avatar
    Did you play with different options under the Echo Control for the device? There is a setting for Echo control under Options-bluetooth-your device properties-echo control.
    02-03-09 07:41 AM
  3. Tinyk's Avatar
    I had exactly the same problem, its not just BB's that do it you can get the problem with some nokia's but the BB does cause it on nearly every one.

    The only work round is to keep the volume turned down as much as possible, drove me so mad i changed my CK7W to a parrot which works perfect. Changing it for another CK7W wont fix it, tried that even tried going back to a version 1 kit and changing to a standard speaker instead of the Stereo speakers, nothing worked in the end.
    02-03-09 03:46 PM
  4. ch33ky's Avatar
    Whilst I feel for people having problems I gotta detail my setup with my Bold working perfectly with Windows Mobile.




    My car has the Fiat Group's Blue&Me (powered by Windows Mobile) so all I had to do was send contacts to the car then press the Windows flag button on the steering wheel and say 'Dial' followed by the person's name and it then makes the call for me via Bluetooth to the Bold. Never fails, never misunderstands... just works. Incoming calls connect through and show me the caller on the dashboard. Brilliant stuff.

    If only everything Windows worked so well!
    02-03-09 05:56 PM
  5. g1rbh's Avatar
    Hoping someone can help me here. I have a BB bold, which is great, I'm very happy with it overall. The only problem I have is that for some reason, when I sync it with my bluetooth car kit (Nokia CK-7W) it creates an echo for the person on the other end. It's quite annoying for them although I can't hear it at all. I had the same problem with my BB 8100 pearl. It seems to be some inherent incompatibility between the BB and the Nokia car kit.

    However, I have tried numerous other phones with the car kit, including iphone, sony ericsson, nokia and all work without a problem, its only having an issue with the BB. Anyone had a similar experience and managed to work it out??

    I have a Bold on UK Orange and have tried the handset with 3 different Nokia CK-7W kits. I'm not the only one experiencing this problem and the echo control on the Blackberry seems to make no difference at all.

    Anyone got a fix or am I going to have to swap over to a Parrot?
    02-04-09 03:00 PM
  6. thedino's Avatar
    Anyone had trouble pairing to a CK-7W? Mine wont connect and comes up with unable to connect to audio device.
    03-24-09 06:11 AM
  7. ikiji's Avatar
    @Billch79/g1rbh: Exactly the same here. CK-7W and Blackberry Bold with noise with echo control on but to no avail, the echo still exists at the recipient's end.

    @thedino: Also had this problem. When the phone would scan for the CK-7W it found it but labeled it as Audio Device and would always fail to connect. Tried deleting the pairing from the phone, turning the ignition on and then back to the off position but leaving the key in. Then held the button in on the car kit for 30secs to 'reset'. Removed car key and put back in and turned ignition on again, depressed the button and then scanned again from the phone but this time waited and eventually the device changed name from "Audio device" to "Nokia CK-7W", then it would connect successfully and has done since.

    Sorry it's a bit vague and not full proof but hope it gives you something to go on.

    Think I'm going to look into the Parrot car kit too. Hopefully it doesn't have the echo.
    08-01-09 11:56 AM
LINK TO POST COPIED TO CLIPBOARD