1. warriorwoman's Avatar
    I was fully charged at 9:30 am and by 12:30 my battery is out - This started happening 2 days ago after I downloaded Trapster. I removed Trapster, but my battery is still draining really quickly. Nothing else is different. Normally, it lasts my all day, even with blue tooth and wifi on.

    Any thoughts? Thanks.
    07-03-09 01:04 PM
  2. skullgame45's Avatar
    Try upgrading your OS...

    Posted from my CrackBerry at wapforums.crackberry.com
    07-03-09 01:05 PM
  3. warriorwoman's Avatar
    i am already using .266
    07-03-09 01:08 PM
  4. skullgame45's Avatar
    .282 is out. Just in case you want to try it out and try fixing your battery issues.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-03-09 01:12 PM
  5. AZBBFAN's Avatar
    are you sure you are not running several programs in the backround?
    07-03-09 01:14 PM
  6. adrush's Avatar
    .282 is out. Just in case you want to try it out and try fixing your battery issues.

    Posted from my CrackBerry at wapforums.crackberry.com
    How can I upgrade the OS manually?
    07-03-09 01:17 PM
  7. skullgame45's Avatar
    This says it's for the 8100 but it's the same method for all models. Instead of the OS and BlingBall links provided within, get the Bolds OS.

    http://forums.crackberry.com/f5/upgr...step-z-188139/


    Posted from my CrackBerry at wapforums.crackberry.com
    07-03-09 01:24 PM
  8. bumblesbounce's Avatar
    Start with the simplest to do / easiest to revert fix...then work your way to swapping OS. Haven't read anywhere that .266>.282 radically drops battery usage.
    07-03-09 02:01 PM
  9. warriorwoman's Avatar
    are you sure you are not running several programs in the backround?
    My husband was playing word mole and left it running - maybe that was the problem? other than that, everything was as usual. I exited out of that and am recharging so i will see how long it lasts now.
    07-03-09 03:05 PM
  10. Username00089's Avatar
    My husband was playing word mole and left it running - maybe that was the problem? other than that, everything was as usual. I exited out of that and am recharging so i will see how long it lasts now.
    I think it would take more than Word Mole to be running for the battery to
    lose power that fast. But let us know how it's working after a full charge.
    07-03-09 03:34 PM
  11. warriorwoman's Avatar
    Update - I removed Trapster and all is back to normal. I have not charged since yesterday at about 2 and I still have 2 out of 4 battery bars.
    07-08-09 10:14 AM
  12. Latch's Avatar
    I just upgraded from 266 to 282 and now my battery, which used to last for 3 days, is now dead inside 10 hours. Nice.
    07-08-09 11:22 AM
  13. laollis's Avatar
    I upgraded from .247 to .282 yesterday because my battery didn't last a day. Well, it's been over 14 hours and my battery is down just a hair. .282 is great imo. Everything works faster too.
    07-08-09 11:47 AM
LINK TO POST COPIED TO CLIPBOARD