1. atsak's Avatar
    Hi all,

    I had a number of issues over the last week or so with unexpected reboots and so on which were getting problematic. Decided to update the firmware to try and work around it. Am with Rogers. BB 9000, went ahead and downloaded the AT&T new firmware and deleted the vendor file.

    The firmware upgrade never proceeded, becuase every time the apploader (DM 4.6, 4.7, or the straight apploader app from both versions) started the "connecting to bootrom" phase the BB went into an infinite loop.

    I have tried:
    1. Following the instructions for deleting the firmware (the JL_Cmder app). This worked fine. So now I have a 507 error (which is better, frankly, than the random irritating reboots).
    2. I removed the SIM and MicroSD card. No change.
    3. I removed the battery but can not turn the BB on or use it without the battery.
    4. Two different computers, one Windows XP SP2 and the other Windows Vista SP1
    5. Tried plugging and unplugging the USB cable at various times during the detection process

    I am now outside my warranty period so would be very interested in any real advice. I have been thorough in following the various suggestions already made on this board, to save everyone doing searches on my behalf.

    Does anyone have real experience with this reboot cycle every time apploader touches the boot rom? More interestingly how did this happen and why?

    09-05-09 12:43 AM
  2. PoShGaL's Avatar
    yep, happened to me last week. Same situation.. make sure you have the exact OS device on your computer & delete the vendor file. Use Apploader to reload your device OS instead of DM.
    09-05-09 01:34 AM
  3. atsak's Avatar
    Yep, have the right firmware (have tried 3 different versions including my provider version) and have been using apploader. Have also tried three versions of the blackberry desktop software to see if that could work around it. None of these things work.

    There has to be a way or another way to reload the boot rom code (well, since it's ROM I guess not) or interrupt the cycle of reboots to force the software in.
    09-05-09 06:39 AM
  4. coggster's Avatar
    If you use the command prompt to load the apploader without using jvm then it should load perfectly. I had a similar issue previously. I should think there is a "how to" on here somewhere about it if you are unsure.
    09-05-09 10:07 AM
  5. atsak's Avatar
    Yep, tried the /nojvm instructions for apploader.exe. That didn't work either. Called Rogers today; it happens it was still under warranty and they're sending me another one. Still, there must be a way to fix this . . .
    09-05-09 10:14 PM
  6. Teek's Avatar
    09-05-09 10:29 PM
  7. atsak's Avatar
    No, I had followed that. I sent it back to Rogers today. The problem was the instant you started to load firmware it would get in a reboot loop. You couldn't get into the boot rom.
    09-09-09 11:03 PM