1. gunner-az's Avatar
    My Surface Pro 3 running Windows 8.1 Pro ran Blend well for more than a year. Suddenly a few months ago it would no longer launch Blend. I would see a brief indication on screen that it was launching but no window would open. Blend ran, and runs, fine on any Windows 7 desktop unit that I use. After some research I realized when looking at the required software components for Blend that Windows 8.1 Pro was not listed as a supported OS but I was busy and not particularly interested in changing the OS on the Surface Pro 3. I guess this was my problem even though Blend had worked fine for me for a year+.

    I finally updated to Windows 10 today. The free upgrade from Windows 8.1 Pro is Windows 10 Pro which I needed since I'm running on a business network. The total time to download and install Windows 10 was maybe 90 minutes. I am now able to run Blend without any noted issues. I did not need to reinstall Blend or do anything special. I simply clicked the Blend icon and it launches and runs fine. I'm very glad to have it back.

    FYI FWIW.
    05-11-16 12:25 PM

Similar Threads

  1. Z10 STL100-1 10.3.2.2987 power issues, how can I fix them?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 11
    Last Post: 06-25-16, 07:49 AM
  2. Hub cut and paste
    By hbelkin in forum BlackBerry Priv
    Replies: 42
    Last Post: 06-18-16, 08:13 PM
  3. EU blocks Three's 10 billion takeover bid for Telefonica's O2
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 05-11-16, 06:00 AM
  4. Portable charger availability in Canada for Z30 and Passport?
    By jic999 in forum BlackBerry 10 Accessories
    Replies: 0
    Last Post: 05-11-16, 05:50 AM
  5. Why Blackberry Blend not loading on Galaxy S2 Tab?
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 05-11-16, 05:22 AM
LINK TO POST COPIED TO CLIPBOARD