1. Vetboy's Avatar
    I've always had weather apps that display the current temp in the status bar. Several days ago, the temp disappeared from the bar. Wondered if it was a setting somewhere, but cannot find anything that should prevent it (also, I never changed any settings to start with). Funny thing is, it disappeared for a few days, then reappeared for a few, and now is gone again. I tried a restart - no help. Tried forcing the app to stop - no help. Tried reinstalling - no help. Just for fun, I tried another weather app with the same feature - no help.

    So at the moment, the temp is in the status bar only when the app is open. As soon as I close the app, the temp goes away.

    Any thoughts?
    08-12-17 08:36 PM
  2. Ecm's Avatar
    Which weather app are you using? And did you possibly tweak the app permissions ?
    08-12-17 09:16 PM
  3. blueyestm's Avatar
    It's a bug in the update that started with the June update. You need to leave the apps open in the background for it to work
    08-13-17 12:40 AM
  4. Vetboy's Avatar
    It's a bug in the update that started with the June update. You need to leave the apps open in the background for it to work
    Weird that it just started in the last few days and that it is intermittent.
    08-13-17 08:46 AM
  5. Vetboy's Avatar
    Which weather app are you using? And did you possibly tweak the app permissions ?
    Changed nothing and it happens with at least the two weather apps that I tried - Weather by Macropinch and Beweather
    08-13-17 08:47 AM
  6. PHughes's Avatar
    Accuweather supports this.
    08-13-17 11:38 AM
  7. Vetboy's Avatar
    Accuweather supports this.
    Sure, but I suspect it will have the same issue as the other two I tried. I don't think the issue is with a given app, but somewhere in the OS
    08-13-17 02:39 PM
  8. PHughes's Avatar
    Sure, but I suspect it will have the same issue as the other two I tried. I don't think the issue is with a given app, but somewhere in the OS
    It woks fine on mine. No need to dismiss the idea before you try it. I thought that's why you asked, you wanted to know what app actually worked. Accuweather's implementation of it works fine on my Priv. I ran it like that for about two weeks, then shut it off since I am using their widget instead.
    08-13-17 02:41 PM
  9. PHughes's Avatar
    It's working on mine as we speak. (write)
    08-13-17 02:45 PM
  10. Vetboy's Avatar
    It woks fine on mine. No need to dismiss the idea before you try it. I thought that's why you asked, you wanted to know what app actually worked. Accuweather's implementation of it works fine on my Priv. I ran it like that for about two weeks, then shut it off since I am using their widget instead.
    What idea? I tried two different apps and they both don't work. I have used both for a long time (at different times) and they worked fine until the last few days. The issues isn't a given app, but something with the OS. And for what it's worth, they both still work on my PRIV also, but neither works on the keyone. The issue is in the OS on the keyone and I was asking if anyone had any insight. Both the apps I mentioned also support this feature and have worked well for years. I'm trying to understand why they have suddenly stopped.
    08-13-17 02:46 PM
  11. PHughes's Avatar
    What idea? I tried two different apps and they both don't work. I have used both for a long time (at different times) and they worked fine until the last few days. The issues isn't a given app, but something with the OS. And for what it's worth, they both still work on my PRIV also, but neither works on the keyone. The issue is in the OS on the keyone and I was asking if anyone had any insight. Both the apps I mentioned also support this feature and have worked well for years. I'm trying to understand why they have suddenly stopped.
    Sorry to try to help. The idea was to try Accuweather since it is working fine on my Priv. Right now it is showing the temperature on the notification bar. I had it working that way for two weeks without an issue, this was in July, and after the last update the end of July, the same OS I am running right now, it was still working. It is working this moment.

    Sorry to suggest something. I am sorry I didn't tell you your OS is the issue. If you already knew what the problem was, why post a thread?

    Have a good day.
    08-13-17 02:51 PM
  12. Vetboy's Avatar
    Sorry to try to help. The idea was to try Accuweather since it is working fine on my Priv. Right now it is showing the temperature on the notification bar. I had it working that way for two weeks without an issue, this was in July, and after the last update the end of July, the same OS I am running right now, it was still working. It is working this moment.

    Sorry to suggest something. I am sorry I didn't tell you your OS is the issue. If you already knew what the problem was, why post a thread?

    Have a good day.
    Um. Ok
    08-13-17 03:04 PM
  13. dpw09's Avatar
    Mine is working on Dtek50 /July.
    08-13-17 05:55 PM
  14. Vetboy's Avatar
    Is Dtek on Marshmallow or Nougat?
    08-13-17 06:08 PM
  15. thurask's Avatar
    Is Dtek on Marshmallow or Nougat?
    Marshmallow.
    08-13-17 06:11 PM
  16. Vetboy's Avatar
    Marshmallow.
    Yeah. That's what I thought. My PRIV is on Marshmallow and the temp shows on the status bar fine (for the same apps). But on the Keyone, which is on Nougat, the temp only shows if the app is open. And this only started several days ago - before that, the temp was always there. I wonder if it's related to the most recent update. Or maybe there's a setting that has changed related to background apps. But after much searching, I can't find anything.
    Last edited by Vetboy; 08-16-17 at 06:31 AM.
    08-13-17 06:22 PM
  17. thurask's Avatar
    Yeah. That's what I thought. My PRIV is on Marshmallow and the temp shows on the status bar fine (for the same apps). But on the Keyone, which is on Nougat, the temp only shows if the app is open. And this only started several days ago - before that, the temp was always there. I wonder if it related to the most resent update. Or maybe there's a setting that has changed related to background apps. But after much searching, I can't find anything.
    That might be due to the past few KEYone updates screwing up background notifications rather than Nougat itself.
    08-13-17 06:50 PM
  18. PHughes's Avatar
    Yeah. That's what I thought. My PRIV is on Marshmallow and the temp shows on the status bar fine (for the same apps). But on the Keyone, which is on Nougat, the temp only shows if the app is open. And this only started several days ago - before that, the temp was always there. I wonder if it related to the most resent update. Or maybe there's a setting that has changed related to background apps. But after much searching, I can't find anything.
    Ah, that would be the problem. You never said you were using Nougat. Yes, on Marshmallow it works fine. It always helps to tell what phone and OS you're using. I was assuming Marshmallow since you didn't say KeyOne. Hopefully with a new update they'll sort it out.
    08-13-17 09:51 PM
  19. Vetboy's Avatar
    That might be due to the past few KEYone updates screwing up background notifications rather than Nougat itself.
    Yup. I could certainly buy that. Hopefully it's fixed with the next update.
    Last edited by Vetboy; 08-15-17 at 09:34 AM.
    08-15-17 07:37 AM
  20. Mrs C 2017's Avatar
    Don't know if this is the answer for anyone else, but my weather & temp doesn't show up in my notifications bar unless location is ticked on in settings. Sometimes it doesn't show up right away just because I switch location on, but in a few hours or If I restart the phone - it shows up & stays put. I rarely have my location on and during those times the weather & temp never shows up in notifications bar. Makes sense to me
    But maybe some already keep location on and something else is causing the problem.
    08-16-17 10:11 AM

Similar Threads

  1. Word substitution fixed on KEYone?
    By iamagod in forum BlackBerry KEYone
    Replies: 8
    Last Post: 08-16-17, 12:49 AM
  2. Phone vibrates when I click on speaker phone button
    By DB911 in forum BlackBerry KEYone
    Replies: 6
    Last Post: 08-13-17, 05:28 AM
  3. Voice recorder on dtek50
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 08-12-17, 07:17 PM
  4. Replies: 1
    Last Post: 08-12-17, 07:16 AM
  5. RSVP Now for a Special Edition CrackBerry Meetup in Berlin on August 31st!
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 0
    Last Post: 08-12-17, 02:00 AM
LINK TO POST COPIED TO CLIPBOARD