1. rgarza8's Avatar
    I tried opening the HUB and a note came up that I needed to update Blackberry HUB+ services. Go to that option and no update. Anyone having this problem? Using android version for Samsung S7
    02-25-17 10:32 AM
  2. JustDontBlink's Avatar
    Same problem here on Priv. "Uninstalled" Hub through Play Store to remove recent updates to get things working.

    Edit: This "fix" returns Hub to an earlier version, not the most recent. My goal was just to be able to open Hub. I suspect an update of some kind from BlackBerry will be needed to actually correct the problem.
    Last edited by JustDontBlink; 02-25-17 at 11:39 AM.
    02-25-17 11:00 AM
  3. zyad's Avatar
    Same problem here on Priv. "Uninstalled" Hub through Play Store to remove recent updates to get things working.
    Same thing happened to me, and I tried what you did, but it reverted the Hub to the much older original version (no Dark Hub, and probably the original version that came with the phone).
    So I "uninstalled" BlackBerry Hub services, updated Hub to try to force the install of the proper Hub Services, updated that again, and I'm still getting the original Hub notice: Hub won't open without an update to services, which doesn't exist on the Playstore. It still shows that I have the latest version of both.
    Device restart didn't work.
    Anyone know a fix?
    My Hub is showing version 1.5.1.12468
    My Hub services is showing version 1.5.0.43353

    If my version of services is outdated, does anyone have an APK of the latest?
    02-25-17 11:30 AM
  4. zyad's Avatar
    Just noticed that Calendar and Contacts have the same problems.
    I just uninstalled all the latest versions of Hub, Calendar, and Contacts. Then I downloaded and installed the February 7th apk's for all of them from various websites in order to revert to the versions before yesterday's updates and turned off Auto-update in the Playstore for the three of them until this gets figured out.
    They are working as they did before today.
    If anyone can confirm the latest version of Hub+ Services on their device, I would appreciate it.

    Edit: Just noticed that the Hub+ Services version that is showing as the latest for me (the versions I listed above) shows as the Feb 1st version in the Playstore.
    I guess my phone got the other apps but the latest Hub+ Services didn't get pushed to it yet?
    02-25-17 12:15 PM
  5. rgarza8's Avatar
    Wow...looks like a global problem. Hopefully they will roll out the update for services soon. I guess I could manually roll back. What a pain but I am so used to the hub that I dont like using any other email on my phone. Its just so efficient. Damn you BB!

    I also looked to see if the updated HUB+ Services was out there usually APK Mirror is a good place to look. Nothing at all.
    02-25-17 12:20 PM
  6. zyad's Avatar
    Can anyone help by telling me the latest and greatest version number of Hub+ Services?
    02-26-17 01:40 PM
  7. JustDontBlink's Avatar
    Found a fix that worked for me.

    I had registered as beta tester for Hub, but not BlackBerry Services. I went back to Beta Zone and registered for BlackBerry Services in the downloads section. Then I went to Play Store, updated Hub+ Services, then updated Hub. Everything working now.
    02-26-17 08:18 PM
  8. zyad's Avatar
    Found a fix that worked for me.

    I had registered as beta tester for Hub, but not BlackBerry Services. I went back to Beta Zone and registered for BlackBerry Services in the downloads section. Then I went to Play Store, updated Hub+ Services, then updated Hub. Everything working now.
    Oh I'm a beta tester too. Was thinking of checking that. I will try it now.
    02-26-17 08:38 PM
  9. zyad's Avatar
    Oh I'm a beta tester too. Was thinking of checking that. I will try it now.
    I just registered and saw "You are a tester" under Hub+ Services but in the Playstore, the update is not showing for me.
    I will check again later.
    02-26-17 08:44 PM
  10. zyad's Avatar
    I just registered and saw "You are a tester" under Hub+ Services but in the Playstore, the update is not showing for me.
    I will check again later.
    Had to uninstall and resinstall Services to get the update, then set up my email accounts again but it worked.
    Thanks.
    02-27-17 12:08 PM

Similar Threads

  1. Not happy with Priv's performance. What's the cause?
    By Nate650 in forum BlackBerry Priv
    Replies: 7
    Last Post: 04-26-17, 01:16 PM
  2. Can TCL "skin" android to look/work like bb10?
    By d987654321 in forum BlackBerry Android OS
    Replies: 3
    Last Post: 02-26-17, 03:58 PM
  3. Hub on BB10 vs Priv/Android (Mercury)
    By mawil1013 in forum BlackBerry HUB+ Suite
    Replies: 3
    Last Post: 02-25-17, 04:06 AM
  4. My scroll button is not working
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 02-25-17, 12:33 AM
  5. Passport does not connect.
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 02-24-17, 09:19 PM
LINK TO POST COPIED TO CLIPBOARD