1. dpeters11's Avatar

    Blackberry 9900 running
    BES 5.0.3MR8
    Mixed Exchange 2007 and 2010, BESAdmin mailbox is on 2010. User mailbox on 2007

    I have a user that recently created some folders under his Inbox. While there are a lot of them, he does not have 500. The recently created folders show up both in OWA and on the BES if I go into that users folder redirection settings. They do not show up on the device. If I create a folder on the Blackberry (including an Inbox subfolder), it shows up in Exchange immediately. I created a folder in Outlook straight off the mailbox, and a subfolder in the inbox, neither showed up on the Blackberry, though both show on BES.

    I have created folders on two other users in their Outlook, one that had been moved to 2010, the other still on 2007. Both worked normally. The Blackberry saw them immediately.

    This is from the MAGT log from the time that he tried to create his folders yesterday:
    [40708] (01/14 13:41:19.082):{0x2080} {user@domain.com} Queuing notification of created folder
    [40115] (01/14 13:41:19.191):{0x29D0} {user@domain.com} FolderState not found for FolderId=-307
    [40569] (01/14 13:41:19.191):{0x2080} {user@domain.com} Queuing notification of renamed folder
    [40717] (01/14 13:41:19.394):{0x29D0} {user@domain.com} SetFolderState - Saved Folder State. FolderID=-307, ParentFolderID=-7, FolderNameHash=9505422, SyncInProgress=true, Redirected=0
    [30253] (01/14 13:41:19.394):{0x29D0} {user@domain.com} Queuing CREATE_FOLDER for device folderID=-307, parentfolderID=-7
    [41079] (01/14 13:41:19.488):{0x29D0} {user@domain.com} PagerImp::SaveChanges: changed items = 60 Size = 4
    [30290] (01/14 13:41:19.488):{0x1F38} {user@domain.com} sending OTAFM command to device, transactionId=-791840052, Tag=3053744, size=74
    [40279] (01/14 13:41:19.488):{0x1F38} {user@domain.com} SubmitToRelaySendQ, Tag=3053744

    Any suggestions? The really bizarre part, I now have created a few more folders on Exchange, and they do show up on the device. The folders already created still do not. Also, I did reboot the device prior to my starting the testing.
    01-15-13 12:21 PM
  2. dpeters11's Avatar
    I think I got it. Turning redirection off and back on seems to have done it.
    01-15-13 01:24 PM