1. Turk54's Avatar
    We have been using BESX for several months now, with no problems until last Friday. We have one user whose calendar and contact records have stopped syncing - well, sort of. New contacts don't sync up, but existing contacts can be modified and two-way sync just fine. No new calendar entries sync either. User did a RSET on calendar to force a reload, and it wiped his calendar entries on the handheld but did not download any calendar entries - so now one pissed off user because he lost all of his calendar entries on the handheld. User did a RSET on contacts, and all previous contacts got sent down (approximately 1000), but no new contacts entered since Friday were sent to the handheld, even though they are on Exchange. Through all of this, emails are working flawlessly.

    I copied all of the contacts to the contacts folder in user
    s Personal Folder, then deleted all of the contacts in the mailbox, sync'ed up with Exchange, copied everything back to the contacts folder in the Exchange mailbox, sync'ed up again, and did a RSET and all of the contacts sync'ed up to the handheld. Two way sync seems to be working once again for the contacts. I then went through the same scenario with the calendar entries, but no dice at all. I'm stymied as to what to try next. I am open to anything you got. Thanks. Any ideas as to what may be the rooot cause?
    06-09-10 07:27 AM
  2. murialita's Avatar
    Have you resent service books or done enterprise activation again?
    06-10-10 03:16 PM
  3. Turk54's Avatar
    Have you resent service books or done enterprise activation again?
    Yes - several times. Still does not sync calendar items, even though everything else is working perfectly. I even did a wipe of the device and still same thing.
    06-10-10 03:21 PM
  4. murialita's Avatar
    One more thought. Have you tried deleting the user's BES account and recreating it?
    06-10-10 03:51 PM
  5. Turk54's Avatar
    One more thought. Have you tried deleting the user's BES account and recreating it?
    Yes - unfortunately that didn't change things. We now realize that more than one user has this identical problem with everything working but the calendar not sync'ing at all. Soemwhat of a head scratcher, since everyone swears that nothing was changed on the Exchange server or system software. Obviously we need to dig deeper.....
    06-11-10 04:22 PM
  6. Turk54's Avatar
    Just an update on our problem for those interested. As my last post stated, we discovered that our contact & calendar sync issues were not isolated instances but rather an issue that affected everyone. In delving deeper, it appears that either an OS update or an update to Exchange has caused BESadmin permissions issues where the SendAs permission is no longer valid. we have done some digging, and have found several posts dealing with the same issue and potential solutions. These have been passed to our admin guy and hopefully we will get this problem resolved soon.

    In any case, there are two documents which have a lot to do with this issue.

    1) The "Send As" right is removed from a user object after you configure the "Send As" right in the Active Directory Users and Computers snap-in in Exchange Server

    2) Users cannot send e-mail messages from a mobile device or from a shared mailbox in Exchange 2000 Server and in Exchange Server 2003

    The amazing part to me is how a perfectly working system got hosed up with automatic updates. More to the point, if/when we get this problem resolved, it makes me wonder what else lies beneath the surface that may pop up and bite us in the ****. We are a small company with limited resources, and the support of BESX is costing us an arm and a leg. I'm not sure where the cut off point is for us, but we must certainly evaluate if using iPhone or Android devices with simple ActiveSync support would be preferable to the headaches of BESX.

    The group's thoughts would be appreciated.
    06-30-10 03:07 PM
  7. Turk54's Avatar
    For those curious about this problem, our issue is finally resolved. The end result was that the Microsoft articles posted previously helped us resolve our problems, as well as another blog post

    Paul's Reflections Blackberry “Send As” Nightmare

    that detailed our problems exactly. In addition, we verified CDO.DLL's matched all the way around to the latest and greatest. Now everything is back to normal and everyone is a "happy camper" once again - at least till the next update occurs.

    Thanks to eveeryone for their comments and suggestions.
    07-09-10 03:29 PM