1. Reaper48's Avatar
    Hi all,
    I wonder if you can help with this problem I am having installing BES 5.0.4 MR2 onto Exchange Server 2013.
    My environment is as follows:
    2 x Exchange 2013 (Build 30516.32) CAS Array FQDN mail.domainname.com
    2 x Exchange 2013 (Build 30516.32) DAG
    2 x High Availability SQL Server 2012
    MAPIcdo version 6.5.9320.0

    All running Windows Server 2012 version 6.2.9200

    I have run through this article making sure to follow every procedure:

    KB33406-BlackBerry Enterprise Server support for Microsoft Exchange Server 2013...
    I get as far as the MAPI settings (Perform View-Only check) and then receive the following error:
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1548: (#30000) ConnectToLDAPServer connects to LDAP server
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1549: (#30000) BindToLDAPServer succeeds to ldap_bind_s to LDAP server
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1550: (#30000) LDAPSearch succeeds with ldap_search_s, search base [CN=*InternalServerName*,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=*Name*,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=*DomainNa me*,DC=local] filter [(distinguishedName=CN=*InternalServerName*,CN=Serv ers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=*Name*,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=*DomainNa me*,DC=local)]
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1551: (#30000) SimpleLDAPSearch2 returned count of 1
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1552: (#30000) LDAPSearch found attribute [serialNumber]=[Version 15.0 (Build 30516.32)]
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1553: (#30000) EndLDAPSession successfully ends an LDAP session
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1554: (#30000) CExchangeServer::GetExtendedInformation received unexpected version [Version 15.0 (Build 30516.32)] for Exchange server [*InternalServerName*]
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1555: (#30000) CExchangeServer::GetExtendedInformation result is [1] - Name:*InternalServerName*,Version:0/0(Version 15.0 (Build 30516.32)),ADFor[*DomainName*.local],GC[Name[cs-mt-dc2v.*DomainName*.local] Addr[172.26.227.22] Domain[*DomainName*.local] Forest[*DomainName*.local] Site[Default-First-Site-Name] SB[DC=*DomainName*,DC=local] PDC=0 GC=1 IsValid=1 NatRetCode=0 LDAPRetCode=0 ET=0 ],DN[CN=*InternalServerName*,CN=Servers,CN=Ex...],EC[CN=...],Org[CN=*Name*,CN=Microsoft E...],AG[CN=Exchange Administrative Gro...],Loaded[1]
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1556: (#30000) CMAPICon::smileyfrustrated:etMAPIUserAndServer from [BES Admin] using GC [cs-mt-dc2v.*DomainName*.local] was [besadmin@*DomainName*.local/*InternalServerName*], return [0]

    This is a multi-tenanted Exchange configuration with GAL seperation, BESadmin account is in the default Global Address List and has visibility over all objects.

    Does anyone have an idea as to why this might be happening or have any other suggestions?

    Thanks in advance.
    09-23-13 12:36 PM
  2. pkcable's Avatar
    I moved this to BB Admins it should get more attention here.
    09-24-13 08:58 AM
  3. smoothrunnings's Avatar
    You need Microsoft CDO for Exchange 2013 which I don't think is even available from Microsoft yet. Do a search on Google for CDO for Exchange 2013 and look at the BES 5 threads. I personally have not been able to find CDO for Exchange 2013 yet from Microsoft.

    Hi all,
    I wonder if you can help with this problem I am having installing BES 5.0.4 MR2 onto Exchange Server 2013.
    My environment is as follows:
    2 x Exchange 2013 (Build 30516.32) CAS Array FQDN mail.domainname.com
    2 x Exchange 2013 (Build 30516.32) DAG
    2 x High Availability SQL Server 2012
    MAPIcdo version 6.5.9320.0

    All running Windows Server 2012 version 6.2.9200

    I have run through this article making sure to follow every procedure:

    KB33406-BlackBerry Enterprise Server support for Microsoft Exchange Server 2013...
    I get as far as the MAPI settings (Perform View-Only check) and then receive the following error:
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1548: (#30000) ConnectToLDAPServer connects to LDAP server
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1549: (#30000) BindToLDAPServer succeeds to ldap_bind_s to LDAP server
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1550: (#30000) LDAPSearch succeeds with ldap_search_s, search base [CN=*InternalServerName*,CN=Servers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=*Name*,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=*DomainNa me*,DC=local] filter [(distinguishedName=CN=*InternalServerName*,CN=Serv ers,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=*Name*,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=*DomainNa me*,DC=local)]
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1551: (#30000) SimpleLDAPSearch2 returned count of 1
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1552: (#30000) LDAPSearch found attribute [serialNumber]=[Version 15.0 (Build 30516.32)]
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1553: (#30000) EndLDAPSession successfully ends an LDAP session
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1554: (#30000) CExchangeServer::GetExtendedInformation received unexpected version [Version 15.0 (Build 30516.32)] for Exchange server [*InternalServerName*]
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1555: (#30000) CExchangeServer::GetExtendedInformation result is [1] - Name:*InternalServerName*,Version:0/0(Version 15.0 (Build 30516.32)),ADFor[*DomainName*.local],GC[Name[cs-mt-dc2v.*DomainName*.local] Addr[172.26.227.22] Domain[*DomainName*.local] Forest[*DomainName*.local] Site[Default-First-Site-Name] SB[DC=*DomainName*,DC=local] PDC=0 GC=1 IsValid=1 NatRetCode=0 LDAPRetCode=0 ET=0 ],DN[CN=*InternalServerName*,CN=Servers,CN=Ex...],EC[CN=...],Org[CN=*Name*,CN=Microsoft E...],AG[CN=Exchange Administrative Gro...],Loaded[1]
    [30000] (09/12 17:53:44.723):{0xABC} <5>Sep 12 17:53:44 *InternalServerName* {0x814} 1556: (#30000) CMAPICon::smileyfrustrated:etMAPIUserAndServer from [BES Admin] using GC [cs-mt-dc2v.*DomainName*.local] was [besadmin@*DomainName*.local/*InternalServerName*], return [0]

    This is a multi-tenanted Exchange configuration with GAL seperation, BESadmin account is in the default Global Address List and has visibility over all objects.

    Does anyone have an idea as to why this might be happening or have any other suggestions?

    Thanks in advance.
    04-22-14 11:01 AM
  4. smoothrunnings's Avatar
    04-22-14 11:09 AM
  5. Sith_Apprentice's Avatar
    haha thank you for posting that, but the thread is from last Sept haha
    04-23-14 09:49 AM

Similar Threads

  1. Recorder+ for BlackBerry 10
    By tonyblaze in forum App Announcements
    Replies: 19
    Last Post: 07-29-14, 05:42 PM
  2. Replies: 7
    Last Post: 10-28-13, 03:26 AM
  3. Blackberry - Who Benefits From A Control Change?
    By tomsobon in forum General BlackBerry Discussion
    Replies: 6
    Last Post: 10-04-13, 09:12 PM
  4. Blackberry Q10 Skype Will Not Open? Help Please :)
    By boooyaaa21 in forum BlackBerry Q10
    Replies: 2
    Last Post: 09-24-13, 01:50 PM
  5. What Now For BlackBerry and BB10?
    By Paul22UDS in forum News & Rumors
    Replies: 4
    Last Post: 09-24-13, 08:50 AM
LINK TO POST COPIED TO CLIPBOARD