1. cmcannon's Avatar
    Just started happening today...

    When I press the SYM key, on the screen it types "b$" and if I push the trackball it shows on the screen as "uo" and type 0 and it comes up as "yi".

    I have no idea how this started and I had used the phone to check email and make a call earlier this morning with no problems. I did have my phone in my pocket earlier and possibly pushed a random set of keys to cause this?????

    I have searched online all day and haven't found anyone with this problem. I have pulled the battery out etc. but this did not obviously help.

    Any ideas or suggestions??

    Thanks everyone in Advance!!
    11-11-07 04:36 PM
  2. jsanders's Avatar
    Often, I hear of users reporting this after some water or liquid damage to the keyboard. Have you had?

    I would first recommend the battery pull (while the device is powered ON) and replace and reboot, which you have done.
    11-11-07 04:43 PM
  3. cheshillsgolf's Avatar
    Try going to options, language, and make sure that"use language shortcut" is off. I had this issue once before and turning that off corrected it.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-12-07 06:22 PM
  4. Tylerd's Avatar
    Never heard of that problem. I have had my trackball and a few other keys freeze but never this!
    11-12-07 07:15 PM
  5. cheshillsgolf's Avatar
    Also, make sure that under options, language, language and input language is set to English. You may have accidentally changed the input language to something else.
    11-13-07 06:33 AM
  6. elproducto's Avatar
    I have the same exact issue as the Op. Did anyone fix this issue I have cleaned the trackball with glass cleaner, and also used the air spray and Still the issue remains.
    01-09-08 06:14 PM
  7. elproducto's Avatar
    Sometime last night the trackball started working properly again, I guess the cleaning was the trick. I tested it then turned it off. I turned it back on today, now all the key work until I use the trackball or hit return. I do a hard reset. Again I am able to use the main keys up until I use the trackball or hit enter, after that nothing can get the display back on until I do a hard reset or plug it in or out of a power source. I did a couple of hard reset and eventually this issue goes away, but as soon as it goes into standby mode the key again do not work. Any suggestion on what to try next?
    01-10-08 02:56 PM
  8. billkee25's Avatar
    I'm having EXACTLY the same issue described. Entering the digit "0" calls up the characters "yi" and clicking the trackball enters the letter "U."


    I haven't found any solution for this anywhere. This is a one week old blackberry, and had not been exposed to any liquid damage. I've hard reset the device dozens of times via taking out the battery, and have done a full data wipe --- still having this problem.

    I'm on an international trip and really need this phone and now can't dial numbers with 0's in them!!! Has anyone seen any way of fixing this quickly???
    03-07-09 02:13 AM
  9. bairdmw's Avatar
    I'm experiencing the same issue as well, except for a few different keys.

    The 'A' key brings up 'uo' on screen
    The Green dial key brings up 'jk'
    The Red end call key brings up 'nm'
    Trackball button also doesn't respond to a normal click, so I have to push hard and this usually results in 2 clicks instead of 1.

    When this first started happening a couple of weeks ago, there were a few other keys doing funny things as well, but now it's just those 3.

    Problem is, when I take it in for service, it starts working OK again. So annoying. Anyone know if this is a hardware or software issue?? I thought it was hardware but it comes and goes, so I'm not so sure.

    Cheers!
    03-25-09 03:43 AM
  10. tarynsport's Avatar
    I am having the same problem and I don't think my phone is under warranty any ideas as if a sortware reinstall would help. I just downloaded 4.5 OS and that is when the problem arose. Thanks for any help in advance!
    04-06-09 09:28 AM
  11. Dangles18's Avatar
    Just had the exact same problem with my bold, and I actually fixed mine all I did was take out the keyboard put everything back together and making sure everything was aligned to spec the way it suppose to be. Then bam! All fixed! My buddy had the same problem too, now his is fixed as well he has the 8330
    08-31-09 05:03 PM
  12. lilimei21's Avatar
    Ccan anybody tell me how to fix the keyboard?. When I press the u key most of the time it does not write anything and sometimes when I am writing there is a space without wanting it to be. Thanks in advance to anyone that can tell me what to do to repair this in a 8320 curve BB
    12-29-09 03:41 AM
  13. talljim's Avatar
    I had exactly the same problem -- "0" key produces "yi", etc -- on my 8820 and fixed it.

    The problem had nothing to do with language settings. I googled for instructions to take the BB apart, took the keyboard off and thoroughly cleaned the circuit board contacts underneath, under the keyboard, trackball and elsewhere, with contact cleaner. It was dirty down there!

    When I put it back together and turned it on, everything worked fine.
    02-27-10 03:45 PM
  14. brokebbuser's Avatar
    I used to like my BB until this crap started..
    10-31-10 01:01 PM
  15. Cocoqueen's Avatar
    i have a load of problems every times a press the home bottom the page for dailing numbers comes up with the text Y and some times YI every time i try to exit it it comes back in oder for me to leave that page i have to consistantly press the home botton but the y and yi keep come up every time i press the home botton its stress full it won't even give me time to wipe the phone or rebot it
    06-01-13 08:03 PM
LINK TO POST COPIED TO CLIPBOARD