1. evrydayzawrkday's Avatar
    I got a 8800 on ebay a while ago.... It had an IT policy and the only way I actually got it off was by using jl_cmder to wipe the whole handheld....

    Now the phone is unlocked from Rogers for tmobile, and I don't get signal (always says sos)....

    I upgraded and downgraded the phone several times from 4.2 to 4.5 to see if that makes a difference, and it does nothing.....

    I tried to send/recieve service books, registering the device and even making the perfered network tmobile and nothing works.....

    ONCE in a blue moon, I may get one bar after a battery pull but other than that its crap....

    Any sugestions? Thanks

    Posted from my CrackBerry at wapforums.crackberry.com
    07-21-08 06:34 PM
  2. StoneRyno's Avatar
    Have you tried carrier BB tech support division or BB tech support? It sounds like a complex issue. I'd hate to assume that some hardware went bad. But if other phones on that carrier get a good signal where you don't and the radio is turned on I'm clueless. I'm with sprint and I know they have tech support agents that are really good at fixing signal issues. After a few weeks of trial and error troubleshooting they solved the signal issue we were having at our summer home.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-22-08 12:56 AM
  3. sunkast's Avatar
    Are you certain it is unlocked? You can check by going to Options / Advanced / SIM. Type mepd. You won't see this come up on the screen, but the device will recognize what you are typing and will display more info after you type it. If the device is unlocked, Network should report as disabled or inactive. If it is active, the device is locked.
    07-22-08 01:03 AM
LINK TO POST COPIED TO CLIPBOARD