1. sherryrn2001's Avatar
    I recently bought a BB 8830 from Ebay that had failed in an upgrade. I got the phone reloaded the OS, called Verizon to activate the phone since I wasn't able to access activation online due to plan change on Monday pending. Went to the BB Home Screen...OOPS! No browser icon. Looked in Host Routing Table..No Entries. Service Books? Nothing. Ok another call to Verizon! She stated that it was due to my phone not having enough service. Now personally i think that 1xev with 3 bars is just fine, she didn't think so. So I'm on my own here.

    Ok, so after multiple reloads of OS, battery pulls, soft resets AND Verizon CS calls, I finally decided to go look at my CDMA Service Edit Screen (##000000 send) scroll down to SIP user ID..make sure its YOUR phone [email protected], assuming you have Verizon. Scroll down 2 lines to MIP User ID and make sure its YOUR phone [email protected], again assuming here, click the menu button, hit save. Voila! The phone should start receiving the service books now. I had sent my service books MANY times and received them all after this process. I now have all service books and the browser icon is where it should be!

    Hope it works for you!!
    06-19-09 09:59 AM
  2. tony bag o donuts's Avatar
    thanks for the post and glad you got it working.
    I have to send service books all the time where its becoming a PITA...and I got my phone new from verizon....but I think has to do with Gmail.
    06-19-09 10:13 AM
  3. Mr. Caseberry's Avatar
    I have the same problem with an 8830 World Edition I just got off of ebay. The browser icon wasn't there from the start I'd have to start it by bringing up the "Switch Application" menu on the applications menu. But then after a software update it won't even work that way. Keeps saying I don't have the service books and Alltel tried sending and sending them and nothing is happening. Is there any way to get this working? No icon, no email application anymore this BB is pretty much useless to me without those 2 things....
    07-28-09 08:21 PM
  4. chrisadams33's Avatar
    I, too, had this issue. Make sure the data is turned on. Manage connections>Mobile Network Option> Data "On". I felt like a few after an hour of messing with sending the service books etc.....
    07-29-09 09:08 PM
LINK TO POST COPIED TO CLIPBOARD