1. tnewton3's Avatar
    My 8800 is showing unknown number when I make outgoing calls as well as when receiving calls. It's like the caller ID has been turned off completely. Please help, batter pull done, switched sim, real close to resetting and seeing if that will do anything.

    Thank you in advance for all your help.
    11-18-08 11:41 AM
  2. jeffh's Avatar
    Make sure you don't have Content Protection turned on and including the Address Book.
    Options / Security Options / General Settings /
    Password: Enabled
    Number of Password Attempts: 10
    Security Timeout: your choice
    Prompt on Application Install: No
    Lock Handheld Upon Holstering: your choice
    Allow Outgoing Calls While Locked: No
    Content Compression: Enabled
    Content Protection: Enabled
    Strength: Strong
    Include Address Book: No

    As for showing your number when calling,
    Green Phone Button / Options / General Options / Restrict My Identity: Off
    11-18-08 10:38 PM