1. pallavik's Avatar
    Hi everyone, a bit of a nation specific problem here: when I save Italian landline phone numbers to my address book - in international format i.e. +/39/local dialling code - I do that the way they are supposed to be dialled which means keeping the zero in front of the area dialling code - which you would normally knock off for just about any other country I have been to. When I then try to dial one such number directly from the address book the device will skip the zero by default - which in most cases wouldn't be required - and that causes the call to fail. So far I had to dial each number using the keypad in order to convince my 8820 to include the zero which is clearly less than ideal a solution. Is there any fellow countryman of mine who can come up with some suggestion so that I can avoid having to punch in 13 digit numbers to call fixed phones in Italy?

    And while I'm at it I have lately been doing quite a few restores from back-ups due to my switching backwards and forwards between OS 4.2 and various flavours of OS 4.5's and every time my contacts get restored without the + at the beginning of the rosary of international and local codes: needless to say that is causing me trouble too.

    Any clued up merciful soul that reads this is most welcome to chip in with any kind of useful info...


    08-29-08 09:35 AM
  2. pallavik's Avatar
    OK everyone, after some more searching - obviously din't look hard enough to begin with... - I found the solution and here it is:

    "I changed the smart dialing country code to unknown and it works fine with italian and american numbers, try that option

    ciao! :-)" many thanks to ciaodom, credit to who deserves it.

    The one and only drawback is that with this setting YOU DO NEED THE + SIGN IN FRONT OF THE COUNTRY CODE or else the call will still fail with the message "number unobtainable"

    Hope this will be some use for someone... Cheers,

    Last edited by pallavik; 09-01-08 at 07:36 AM.
    09-01-08 07:28 AM