12-11-09 10:42 AM
305 123 ...
tools
  1. JRSCCivic98's Avatar
    OK, I'm sure some of you migh remember a while back a woman posted on there that her 8830 ringer had just gone to BLAST for no apperent reason one day. Of course after a battery pull it went back to the old BS level.

    Well, today it happened to me. No changes, no nothing. I received an SMS and the volume of the alert while in holster was really loud for some reason and surprised me. I paid it no attention and though perhaps I was just in a quiet environment, until I remembered the posts on here and decided to check the ringer volume as well. So, I pulled out the phone and went to profiles and to edit the ringer and the damn thing was BLARING!!! On High, the volume is just as high as it is when the ringtone is played through the Media Player at Full Volume. When changed to Medium and Low, the volume drops some respectively, but is still very nice and audible. These wacked out sound levels would definatly make the phone sound better. Private people could use the Low level and others could use Medium and High as needed. I can tell you that High should have no issues being able to hear it whereever you are.

    So, that's all well and good, but wtf changed. At first I thought it was some kind of stabiliy issue because this morning I was getting a bunch of java socket errors in OperaMini and didn't reboot at all after seeing all those. So, I decided to look in the Even Log and see what's up. Well, it appears that an error was being generated by the AlertEngine (portion of OS that is used for Ringtone and other Alert playback) as such: AlertEngine: playerUpdate - error : 5. Well, I then decided to play with the volume control and watch some videos and listen to ringtones and music in Media Player to see if messing with that engine would have any adverse affect on the ringtone volume. None of it did... the ringer still continued to be loud and no other Event Log errors were being reported except for the AlertEngine ones. So, now I thought that there was obviously some kind of stability issue with the AlertEngine and would need to test the restart ability of the BB to see if it would clear it or cause it to continue. I knew a battery pull would most likely cause it to clear up so I decided to do a 3 finger salute and gamble that the first time it would do a warm boot. Well, wouldn't you know it that apperently OS4.5 likes to do cold boots more often then 4.2 did when you hit CTL+SFT+DEL. So, darn, I couldn't test it to see if the bug would survive a warm boot. Anyway, after startup of course the ringer was back to it's old *** self and low again, but at least now I know what this other person had experienced first hand. I will continue to see if I can duplicate this in an effort to find a fix for everyone, but no promisses.

    Sorry for the book, but I wanted to let everyone know that the 8830 most certainly has the ability to ring LOUD... RIM just chose not to make it so. There is nothing on CDMA technology or otherwise that limits the ringer capabilities of this phone, so those one and two people who came up with those ideas are well... full of it.

    Here's to hoping there's a fix for this soon. RIM, I hope you're reading this. :thumbsup:


    Edit:

    Read below post for instructions!!!
    Last edited by JRSCCivic98; 07-02-08 at 09:09 PM.
    07-01-08 01:58 PM
  2. KarlyT's Avatar
    I for one will keep my fingers crossed for you to find the fix. I can't believe how much LOWER the ringer is after installing v4.5. It was low before, but this is ridiculous!! Good luck!
    07-01-08 03:53 PM
  3. snowboarder61's Avatar
    I for one will keep my fingers crossed for you to find the fix. I can't believe how much LOWER the ringer is after installing v4.5. It was low before, but this is ridiculous!! Good luck!
    Wow, i don't remember reading about that... but this is good news to hear considering our ring volume sucks to begin with right now.... lol

    After i updated to 4.5 i didn't notice any drop in my ringers, but then again, i am using ones i created also... Are you using stock ringers Karly?

    Regardless, it's good to know there might be a solution...
    07-01-08 04:27 PM
  4. JRSCCivic98's Avatar
    Oh yeah, something I forgot to add above. It seems even after the cold boot, the log still shows the same AlertEngine: playerUpdate - error : 5 error when you play ringtones in Profile/Edit, so that's unrelated to the increase in volume out of nowhere.
    07-01-08 04:32 PM
  5. JRSCCivic98's Avatar
    Holy ****!!!! I just stumbled over what caused my phone to go full blast today.

    Read post below for instructions!!!
    Last edited by JRSCCivic98; 07-02-08 at 05:50 PM.
    07-01-08 10:01 PM
  6. JRSCCivic98's Avatar
    *UPDATE*
    If you are running OS4.5.0.101 on your 8830, this fix will no longer work for you. The last known supported OS was 4.5.0.77. Blame RIM for messing it up for you.


    OK, forget all that BS above (I edited the posts anyway to reduce confusion). I made this even easier for you guys to get your ringer loud.

    See the next bolded line right under this sentance? Do this from your PC, NOT THE BB!!! Also, if you are viewing this post in the WAP site for this forum... better get on your PC, because you won't see the link for the download.
    Download this video, unzip it and put it on your BB under Videos. ***DO NOT MOVE THE VIDEO WITH MEDIA MANAGER AND DO NOT CONVERT THE VIDEO IN ANY WAY!!!*** Then do the following.

    1) Restart the phone. (Full cold restart/Battery Pull - Optional)
    2) Open up Media Player and watch the video all the way to the end.
    3) Back out with ESC key (right of Pearl) all the way back to home screen.
    4) Go into Profiles/Advanced, highlight Normal and hit Menu/Edit.
    5) Cursor to Phone and hit Enter.
    6) Highlight Volume setting and flip around to check loudness.

    If you did everything correctly, your ringer will be REALLY loud.

    This is not a permanent fix. If you restart the phone, you'll need to play the video again to get the loudness back. Also, with the fix applied, the Trackball Click sound will be gone as well.

    This has only been tested on an 8830 w/OS4.5.

    Testing shows that this currently works only with OS4.5.

    I make/give no basic or explicit warranty with the use of this procedure or attachment. Use at own risk. (This is for all the crybaby noobs who freak out at the littlest thing.) It's really getting lame that people have to make disclaimers like this for offering help. Man up you weenies.


    *UPDATE*
    This fix will no longer work if you're using one of the newest versions of 4.5. (i.e. if your platform on the OS is 3.4.x.x, THIS WILL NOT WORK FOR YOU.) Last tested OS with 3.2.x.x platform that still allowed this to work I belive was 4.5.0.77 OS Version.
    Last edited by JRSCCivic98; 03-11-09 at 08:10 AM.
    07-01-08 11:38 PM
  7. snowboarder61's Avatar
    Damn, I wish I was at home to try it out.. Just left on the road won't be home til tomorrow.. I hope there is a perm. Fix soon though... If it works, awesome job on re-duplicating it!

    Posted from my CrackBerry at wapforums.crackberry.com
    07-02-08 12:23 AM
  8. FF22's Avatar
    I have not tried it yet but I do remember when that woman posted about the ring volume increasing and some other guy also posted that he had it for a while, too.

    I will say, that there are aspects of Rim/BB that are not desirable from an owner point of view - this bug has been around for a long time, and, yes, folks have found workarounds but on an expensive device such as this Rim should have solved it early on. I also find the vibrator almost useless but that is probably more a physical design flaw that cannot be overcome with software/firmware fixes. The thing would need a new PURR engine.
    07-02-08 08:34 AM
  9. JRSCCivic98's Avatar
    ^^^ That's nice, we all know that. I need people to try this and give feedback "on the tests". I want to see if this is a workaround just for certain 8830s or all. I'm currently working on finding out why this is triggering the loud volumes, but I need some people to test this. I even made it easy for you guys.... play a video, have loud ringers. WTF, just try it please.
    07-02-08 08:45 AM
  10. snowboarder61's Avatar
    Holy **** dude! That thing is ******** loud afterwords... Just a heads up though I don't think volume matters in the video... It worked with mine only set to two bars! Great find JRS!

    Posted from my CrackBerry at wapforums.crackberry.com
    07-02-08 09:10 AM
  11. snowboarder61's Avatar
    Testing it out also, on low it is quite a bit higher than my old loud was... Crazyness...

    Posted from my CrackBerry at wapforums.crackberry.com
    07-02-08 09:13 AM
  12. JRSCCivic98's Avatar
    Holy **** dude! That thing is ******** loud afterwords... Just a heads up though I don't think volume matters in the video... It worked with mine only set to two bars! Great find JRS!

    Posted from my CrackBerry at wapforums.crackberry.com
    Frack yeah!!!! Now I don't have to shoot a video of me doing it to proove that it works.

    It's good you included the "you don't need to have the volume at 3 thing". It was late last night when I was working on this and just wanted someone else to try it with the same procedure I was using since I didn't want to take the time to figure out exactly what's going on.

    BTW, if this works for anyone, please post what OS version and BB model you're running. I've only tested it on OS4.5 so I don't know if this is just a glitch that can be exploited in 4.5 or other versions as well. Let me know and thanks for testing!!!
    Last edited by JRSCCivic98; 07-02-08 at 06:22 PM.
    07-02-08 09:18 AM
  13. jdwx's Avatar
    After doing this, will you hear the louder ring by browsing the ringer in that profile, or do you have to wait for an actual call?

    I'm not hearing a difference in browsing the ringer in the profile but haven't received a call yet(this is the only phone I have here now).

    Alltell 8830we
    OS 4.2.2.123
    07-02-08 09:56 AM
  14. JRSCCivic98's Avatar
    No, the volume change will be heard in the profile change as well. Sometimes if you don't do it "just right", you may need to try it again. One user has already had success with it.
    Last edited by JRSCCivic98; 07-02-08 at 10:06 AM.
    07-02-08 10:01 AM
  15. JRSCCivic98's Avatar
    OK, I just verified this. This should work for people with an 8830 and OS4.5.
    Last edited by JRSCCivic98; 07-02-08 at 06:23 PM.
    07-02-08 10:05 AM
  16. BBIronMan's Avatar
    I want not able to replicate on a VZW 8830 running the current carrier 4.2 release using your latest simplified instructions.
    07-02-08 10:07 AM
  17. jdwx's Avatar
    Well. I've done this 2x after reading the last post.

    I'm quite sure I'm following procedure.

    but, when I "Highlight Volume High and flip to Escalating and back to High within 2 secs" the ring I hear as soon as I toggle it back to the "high" setting is no louder than it is normally.
    07-02-08 10:11 AM
  18. JRSCCivic98's Avatar
    Still like to hear from more people, but it seems this "trick" may only work under the currently available OS4.5.
    07-02-08 10:12 AM
  19. jdwx's Avatar
    Well, I'm thinking the people that had previously reported the suddenly nice loud ringer, were reporting this happening prior to 4.5's release weren't they?

    I will try a few more times..
    07-02-08 10:16 AM
  20. the_elf's Avatar
    The volume on my 8830 has never been "overpowering," but also never so mute that I can't hear it at all.

    JRSCCivic98's procedure did not enhance the loudness of my ring any. I'm running v4.2.2.148.
    07-02-08 10:18 AM
  21. AirSupply's Avatar
    I have two quick questions:

    - How to full reset 8830?
    - What's ECS?
    07-02-08 10:22 AM
  22. jdwx's Avatar
    Ok, tried two more times and not hearing a difference.

    Alltel 8830
    OS 4.2.2.123
    07-02-08 10:27 AM
  23. AirSupply's Avatar
    OMG ^___^ Unbelievable !!! I did it, and it worked perfectly .... hooorayyyyyy

    I love u JRS, ^___^

    (I am using Alltel BB8830 with OS 4.5)
    07-02-08 11:13 AM
  24. snowboarder61's Avatar
    Yup I'm on 4.5 with 8830WE JRS.... I think you've found a glitch that we will be able to use well at that... And for what its worth to everyone else, if you play a ringer in media at full blast, that's how loud my loud ringer is now....I didn't think it would be video specific either... Sweetness 1 issue down 1 to go... lol (its a verizon thing, you wouldn't understand!) Batches.....

    Posted from my CrackBerry at wapforums.crackberry.com
    07-02-08 11:14 AM
  25. GAM3INO's Avatar
    I can't duplicate this running 4.2.196. Wish I could though! Maybe this will make me go ahead and put 4.5 on my phone!
    07-02-08 12:02 PM
305 123 ...
LINK TO POST COPIED TO CLIPBOARD