1. nandaniya's Avatar
    Hi All,

    i am in India, using a 8830 WE on Vodafone IN. despite trying everything i am not able to register my device with the service provider and so i am not able to use the BB internet services. i have tried everything, changed my SIM card thrice (as suggested by my service provider), removed the battery & put it again, sent the registration message from the HRT, it says registration message sent but then nothing happens, nothing seems to be working out. And at last the service provider said that if the device is not registered with us we cant do much about it.

    i bought the BB unlocked, we bought 5 devices at the same time and only mine is facing the registration issue.

    Anybody can please help me getting my device registered.

    Thanks.
    05-10-11 02:26 AM
  2. Chinkurli's Avatar
    Who is your service provider - Vodafone? Did you try switching another SIM (a different BB activated SIM) to see it works? If so, I just posted the exact same problem after Vodafone guys prefered to blame Verizon for it.
    05-16-11 12:31 PM
  3. nandaniya's Avatar
    Yes my service provider is Vodafone.

    I tried another Vodafone SIM which has BB services activated, that is working perfect, i even tried an Airtel BB activated SIM and that too is working perfect.

    As advised by Vodafone customer care, i have replace my SIM, thrice , but no results.

    Can you please let me know what did you do to resolve the issue?

    Thanks.
    05-16-11 04:50 PM
  4. QWKSNKE's Avatar
    Have you changed the settings in the berry from 1XEV to GSM?
    05-22-11 09:47 PM
  5. nandaniya's Avatar
    Yes, as i am using a GSM network, i have changed it to GSM. But i have tried every possible combination, but i am not able to register it. I even tried using another BB activated Vodafone SIM and with that SIM its working all fine, i am getting GPRS in caps and receiving all the settings but its just not working with my SIM.
    05-24-11 06:56 AM
LINK TO POST COPIED TO CLIPBOARD