1. dhogan17's Avatar
    Just got the 8830 World Edition a few weeks ago and noticed an annoying problem I would like help with...

    I have a full list of contacts loaded in my Address Book...and when one of them calls, the device IS NOT showing the associated name of the number that is dialing-me.

    After I decline answering the call (or after answering it)...I can look in the Call Log and the device displays the associated name. Its just while I am receiving the call, it does not show me that information.

    Any thoughts on what the problem is (a bug? a setting that I am missing? something else?)

    Thanks in advance for any help.
    08-10-07 12:33 PM
  2. kaiyu's Avatar
    You have Content Protection turned on, yes? Go to Options > Security Options > General Settings and set Include Address Book to No.

    I ended up disabling Content Protection entirely because it hosed the Tasks and Memo indices so that Find wouldn't work.
    08-10-07 08:53 PM
  3. TheReviewer's Avatar
    Hi there,

    This is an old entry and the questioner must not be seeing this answer. however for benefit of users like me frustrated with this problem, I've the solution now! Whatever Kaiyu has suggested is correct and at first it did not make sense to me as to how this problem may be related with content protection.

    Thanks Kaiyu for providing the solution.

    Here are the details.

    CAUSE: This happens strangely because of the "Content protection" feature of the blackberry.
    The problem is seen worse when you see that some caller names are shown and not all. This happens due to the time when this setting is enabled. The entries added after this will be protected

    RESOLUTION:

    This is for my model blackberry 8700c
    Goto Options -> Security options -> General Settings

    Scroll Down to section starting with "Content Compression"
    Look for "Content Protection" It must be "Enabled"
    You can disable it at this level (not recommended) to disable the protection for all contents.
    Specifically you can disable it for Address Book By setting "No" for "Include Address Book"
    This way the address book will be available even if the other contents are protected when a call comes.

    Would appreciate logging a message to me if this has saved your life!!!
    Last edited by TheReviewer; 06-16-09 at 06:24 AM. Reason: Correction
    05-16-09 11:15 PM
  4. fortlady's Avatar
    Yep, the solution worked great for my Blackberry Curve. I only started having the problems when I activated the Enterprise solution for work. I'm hoping my car creates an address book again now that I have changed this setting (all my contacts were deleted from my car address book with Enterprise activation)
    12-01-09 03:09 PM
  5. Dragonheart's Avatar
    Hello
    Anyone have a solution for the storm thay told me it was a app the i downloaded but still happen even when deleted the apps sometime it shows for the same person sometimes it dont.
    12-24-09 08:52 AM
  6. iwantmorejavier's Avatar
    kaiyu and TheReviewer... THANK YOU! This issue was starting to drive me crazy.

    I have the BES on my BB so the first place I went to was my company's IT group - They were essentially useless. "It seems this is an issue with your carrier so reach out to AT&T." I was skeptical it had anything to do AT&T but I bought it...

    I went to an AT&T store and they couldn't figure it out either. They actually recommended that I search for my issue at CrackBerry.com because they had never heard of this "problem." Needless to say, I am very thankful this Christmas you guys had a solution waiting for me. Thanks again!
    12-27-09 10:18 AM
  7. Jeepers1979's Avatar
    Thank you! Thank you! This worked for my BB Tour!!!! TheReviewer-wanted you to know it did save my life!!!!

    Posted from my CrackBerry at wapforums.crackberry.com
    01-15-10 08:43 PM
  8. Jeepers1979's Avatar
    Hi there,

    This is an old entry and the questioner must not be seeing this answer. however for benefit of users like me frustrated with this problem, I've the solution now! Whatever Kaiyu has suggested is correct and at first it did not make sense to me as to how this problem may be related with content protection.

    Thanks Kaiyu for providing the solution.

    Here are the details.

    CAUSE: This happens strangely because of the "Content protection" feature of the blackberry.
    The problem is seen worse when you see that some caller names are shown and not all. This happens due to the time when this setting is enabled. The entries added after this will be protected

    RESOLUTION:

    This is for my model blackberry 8700c
    Goto Options -> Security options -> General Settings

    Scroll Down to section starting with "Content Compression"
    Look for "Content Protection" It must be "Enabled"
    You can disable it at this level (not recommended) to disable the protection for all contents.
    Specifically you can disable it for Address Book By setting "No" for "Include Address Book"
    This way the address book will be available even if the other contents are protected when a call comes.

    Would appreciate logging a message to me if this has saved your life!!!
    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    01-15-10 08:44 PM
  9. Jeepers1979's Avatar
    Thank you! This is exactly what I needed to resolve my caller I'd problem on my tour.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-15-10 08:45 PM
  10. keithngo's Avatar
    thanks for the info
    02-07-10 06:02 PM
  11. mdiya's Avatar
    i get the caller id NUMBER DISPLAY , but it does not show the name as shown on my address book . i mean . if the number is 0508217745 , and ive save it as JOHN 0096650 8217745 , it still shows only the number and not JOHN .
    05-01-10 10:15 AM
  12. lou28's Avatar
    i am searching this site for the same problem.....can you shout me if you find the solution please :O)
    thank you
    x
    05-31-10 02:05 PM
  13. Omero_74's Avatar
    Thank You so much kaiyu and TheReviewer.

    Actually, when I started having this problem google maps stopped identifying my location, it seems that it's related somehow. I went to the carrier and from shop to shop with no solution until someone sent me this precious link.


    Regards,
    08-16-10 02:16 AM
  14. keithinsac's Avatar
    So, what if you don't have a general settings option in "Go to Options > Security Options > General Settings"? I have the BB 8530 and the only options I see are Advanced Security Options, Encryption, Firewall, Information, and Security Wipe.

    Thanks in advance.
    10-26-10 12:19 PM
  15. keithinsac's Avatar
    Sorry everyone, I found the answer in another post that's related. I'd post the link but I'm too new a member and the forum won't let me.

    Its this thread -> forums.crackberry.com/f137/curve-8530-caller-id-498345/

    The setting is under Options > Security Options > Encryption: Include Contacts: No.
    10-26-10 03:26 PM
  16. smertz's Avatar
    Thanks! Works on my 9900 now!!



    Sorry everyone, I found the answer in another post that's related. I'd post the link but I'm too new a member and the forum won't let me.

    Its this thread -> forums.crackberry.com/f137/curve-8530-caller-id-498345/

    The setting is under Options > Security Options > Encryption: Include Contacts: No.
    05-11-12 06:04 AM
LINK TO POST COPIED TO CLIPBOARD