1. dakotaspeir's Avatar
    Whenever someone calls my phone it does not display the name just the number and way to fix this?
    04-26-08 08:19 AM
  2. jsanders's Avatar
    There could be any one of three solutions... Try these:
    1. Make sure you set your own country code at Phone Dialer Screen > Options > Smart dialing.
    Set your country code in this format: "+xx" where xx = your country code. Some countries have two or three digit Country Codes. Do not place the '+' in your contact's entry.
    • In the US, set this Country Code as "+1", and place your loca area code in the proper box (this normally the default setting in a new BB).

    2. At the same location, change the National Number Length to the number of digits for your country (since some countries will have less than 10 as set as the default in the BB). Find out the total digits, minus the country code. Do not place the '+' in your contact's entry.
    • For example, some countries have a total number to 8 (plus 3 for country code). You would enter "8".

    3. You may have "Content Protection" set on your Address Book.
    Look at Options > Security > General Settings. Scroll down to Content Protection > Include Address Book = NO.
    04-26-08 08:21 AM
  3. dakotaspeir's Avatar
    Alright thanks alot. It was number 3
    04-26-08 08:28 AM
  4. jsanders's Avatar
    Very Welcome!
    04-26-08 08:31 AM
  5. BerryLatina's Avatar
    Just came across this thread - my 8800 was doing the same thing. Figured maybe because I'm in Germany...

    Numbere 3 solved it - GREAT!!! Much thanks!!
    04-26-08 09:22 AM
  6. kikarose's Avatar
    Thanks for the info - solved my problem with this too!

    Kika
    04-26-08 09:43 AM
LINK TO POST COPIED TO CLIPBOARD