1. jackj04's Avatar
    I just installed the new OS and now my battery will not charge. I tried my wall charger, car charger, and connecting it to my computer. Funny thing is when I connect my bb to the computer, I can sync and my computer recognizes my phone - it just won't charge! I had a backup battery and that did not work either.

    I tried battery pulls 4 times but no resolution. Any ideas? I like the new OS and would prefer not to downgrade. I am on the Verizon network.
    04-18-09 12:02 PM
  2. JoeyMoose's Avatar
    Thats odd i've never heard of that issue before.
    04-18-09 12:37 PM
  3. saintj's Avatar
    I have. Its not the os its the device. I had a 8830 where the charging port had become loose inside the phone. You'll have to have it replaced
    04-18-09 03:01 PM
  4. cabinfever's Avatar
    I have the same issue. I upgraded to the official 4.5 OS on my 8830 and now my battery will not charge? Anyone know if there is a fix for this?
    04-22-09 12:27 PM
  5. shillson's Avatar
    I don't think it's the device. My battery was charging fine on OS 4.2, but the minute I upgraded to 4.5, it stopped charging. When I downgraded to 4.2, it started charging again.
    04-23-09 05:07 AM
  6. radar-man's Avatar
    I just upgraded my 8830 to V4.5 (yes I am way behind the times!!!). Low and behold, it won't charge. I downgraded to V4.2, and it charges again. Anybody else experience this?
    02-22-10 05:14 PM