1. sbojrab's Avatar
    I have a 883 World Edition with PagesPlus service (Verizon Towers). Have unlimited text/voice and 20mg data monthly. Everything was working well, email accounts, browser, etc. I hooked up phone to laptop and started Blackberry Desktop Manager and looked for updates. Did the update and now I have NO browser icon. Cant figure out how to get it back. Otherwise phone works fine, texting, BUT....It is as if I have no wireless web service at all, cant send or receive from my 3 email accounts now. Any input??????
    01-07-10 11:58 PM
  2. jeffh's Avatar
    You have to re-register after an OS Upgrade. Options / Advanced Options / Host Routing Table / Register Now.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-08-10 12:03 AM
  3. sbojrab's Avatar
    I did that...twice...and turned the phone off, took the battery out for 5 minutes, restarted it. Still no browser...

    Anything else it could be? I go to blackberry app world and it says "data service not operational"

    under Services Status it says
    Status: Available
    Connection: Mobile Network
    Blackberry Internet Service: not connected
    Blackberry Enterprise Server: not connected
    Mobile Network: 1XEV
    Mobile Network Provider: not connected
    Bluetooth: off
    01-08-10 12:22 AM
  4. jeffh's Avatar
    Use the Email Setup Wizard on your 8830 to re-send your Service Books.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-08-10 12:26 AM
  5. sbojrab's Avatar
    Sorry to be dense....but how do I do that? I can't email anything, apparently I am not connected to any newtwork anylonger....very frustrating. Just wanted to check for updates and now I have no internet/web connection at all!

    I checked my service provider, and my service is the same as it ever was, and I should have access to the data connection.
    01-08-10 12:36 AM
  6. Thumber1's Avatar
    Hi sbojrab, BB 8830WE register in case of (no browser) - Go to Options tool, click Advanced Options, then Host Routing table. When list comes up, click your menu key by roller ball and click Register Now. When you back out of those, you should have a working browser. Happy surfin!
    01-08-10 10:16 AM
  7. pdcl's Avatar
    Hi,

    I am having the same problem. I just got a phone from ebay. Had 4.2, upgraded to 4.5 in order to get rid of an IT Policy. When I did, I lost the browser and all email capabilities. When I go to set up email, the only option I have is BES email. Before I upgraded, I had already added a personal email address that worked fine (as did the browser).

    I tired to "register now" as listed above, but that didn't do anything. When I go into DM and try to load/unload apps, the browser is already checked and grayed out.

    Any other ideas?

    Edit: I can still receive email from the personal address I enabled before the update, but I cannot reply. I also got a registration email after the "register now" step, but still no browser icon or email setup.
    Last edited by pdcl; 01-09-10 at 10:02 AM.
    01-09-10 09:24 AM
  8. pdcl's Avatar
    Well, I cannot post links, but I tried a bunch of different things from a search and fixed the problem.
    01-09-10 10:30 AM
  9. jeffh's Avatar
    That's great that you were able to find the solution. Can you describe it in words without posting links? That could help the next person who may not know how to search as effectively.
    01-09-10 10:45 AM
  10. sbojrab's Avatar
    I still cant get my browser to appear! when using the desktop manager software, I see the browser, but it is greyed out and I cannot check/uncheck it.

    I did the steps described above (advanced options, routing table, etc) several times, and it says its registered, but no browser or email capabilities. This is frustrating, I may jnust go get another phone.
    01-09-10 04:49 PM
  11. pdcl's Avatar
    Do a search for "browser" in the 8830 WE forum, and read through the thread titled 'No "Browser Configuration Service Book Entries"'. I literally tried everything posted. It finally took when I did a battery pull. Maybe some intermediate step worked and I just didn't so a battery pull, and I could have been done faster, not sure.
    01-09-10 08:17 PM
  12. 312's Avatar
    01-11-10 02:03 PM
  13. camry's Avatar
    Thank you for posting this information. I updated my blackberry for my 8330 and was experiencing the same issue of the same issue with no browser. The problem was fixed just as JeffH stated " .. Options / Advanced Options / Host Routing Table / Register Now. I was sent an email stating that the browser was working. Thanks a bunch JeffH, you're the bomb!
    01-12-10 12:41 AM
  14. skyline247's Avatar
    I bought my 8830 WE off of eBay, and when I send the registration, it says, "registration sent", but to no avail. Do I need to start a data plan with Verizon before they will send my service books?
    01-12-10 12:08 PM
  15. fatyouthminister's Avatar
    more often than not this is a timing issue. if you reboot before your phone is registered then you miss the app introduction.

    Try this:
    Options / Advanced Options / Host Routing Table / Register Now
    ...then wait for the message response that says your phone is registered.

    then power off, pull the battery, wait thirty seconds and reinstall, power on and your new registrsation settings are loaded as well as your app icons.
    02-04-10 03:20 PM
LINK TO POST COPIED TO CLIPBOARD