1. tdjdt4's Avatar
    I have two email accounts set up on my phone and right now all the messages are going to the same inbox. How do I seperate them so each email account has its own inbox?
    02-29-08 09:59 AM
  2. Adam Zeis's Avatar
    By default they all land in the inbox. You should have individual icons for each address you setup that will show you only those messages though.
    02-29-08 10:05 AM
  3. mothy's Avatar
    Is one of them a BES account? If so you need something to seperate them like Empowers BES Mailbox app.
    02-29-08 10:28 AM
  4. jimmers's Avatar
    Go into your email and press the options button (the one with the BB logo on it). Then select Options-->General Options-->SMSand Email Inboxes. You need to select "Separate" and you will have separate boxes for each account.
    02-29-08 10:42 AM
  5. dontworryboutit's Avatar
    That only seperates the SMS inbox from the email inbox. Do you have to have a third party app to seperate the gmail account from the BES email? As of now, I get both gmail and company email in the same inbox. Any thoughts?
    03-06-08 12:44 PM
  6. sunkast's Avatar
    You should have an icon for each email account.
    03-06-08 01:25 PM
  7. dontworryboutit's Avatar
    Not on mine. I have the messages icon for everything that comes in, and the white mailbox for gmail. I do not have a BES only mail icon. How would you go about getting that?
    03-08-08 10:56 AM
  8. Legacy777's Avatar
    Not sure if you got this resolved, but I'm looking to do the same thing.

    Just to add or clarify. Each email account has a separate icon. One is the standard Messages icon which is associated with my company BES and the other is my personal email. The problem is that when I go into the messages folder, it has my work email, inbox & sent as well as my personal email that has been received & sent. If I go to my personal email it only has my personal email, but I want to keep work and personal email completely separate.

    Is there any way to do this?

    (I've just started searching, so maybe the answer is already out there)

    Thanks
    Josh
    03-27-08 05:27 PM
  9. Legacy777's Avatar
    This is about all I found

    (insert http)

    forums.crackberry.com/f6/multiple-email-accounts-need-separate-folders-7107
    03-27-08 06:02 PM
  10. yellowvodka's Avatar
    You should have a icon for each e-mail account
    03-28-08 07:07 AM
  11. Legacy777's Avatar
    I have an icon that is listed messages, all the messages from my company email, from the BES go here. When I setup my personal email, I do get a separate icon for it, however, as you mentioned, my personal email and work email all go to the messages icon. I don't really want to intermingle work & personal email messages.

    From the link I posted, it looks like the only thing to do to fix this is to run a 3rd party app.
    03-28-08 07:41 AM
  12. JazzeeJEF's Avatar
    Maybe the icons for each email is hidden...Try going to show all in the menu option and unhiding them
    03-28-08 09:20 AM
  13. cramosmia's Avatar
    Hello all.

    Had the same problem. Logged into my carriers website and recent the service books.

    Now I have 2 mail icons, one for BES and one for personal.

    CAR
    05-08-08 02:44 AM
  14. username's Avatar
    I agree for the nth time. You should have individual icons for each email add that you have. The "messages" folder is your one-stop location where you can see all your messages (all emails, sms, I get yahoo msg there too).

    Posted from my CrackBerry at wapforums.crackberry.com
    05-08-08 05:21 AM
  15. dgberry56's Avatar
    Can you tell me how to set up the separate BES icon?
    05-15-08 03:50 PM
  16. WillyB88's Avatar
    ok, i too do not have a seperate folder for my BES email account. i have a gmail account and work account that i want to remain seperate. gmail has its own folder and works great. i have no seperate folder for my work email. just the messages folder that both work and gmail go into. i want to have a seperate work email folder. i have checked the hidden folders and nothing is there. work email only goes to messages folder.

    is there a way to stop gmail from going into the messages folder? that would solve the problem because then the work would be messages and gmail would have its own folder since it already does.

    very frustrating!!! please help.
    05-21-08 09:38 AM
  17. osc1's Avatar
    hi i have the same problem with my curve, have you managed to find a fix?
    05-30-08 01:39 AM
  18. tmems's Avatar
    Your only option is to use a 3rd party app like EmPower.
    05-30-08 08:47 AM
  19. latina berry's Avatar
    You should have an icon for each email account.
    05-30-08 09:08 AM
  20. zee921's Avatar
    Is it possible to completely remove one of the email adresses? I had two addresses set up on my phone but I no longer want one of them. I deleted it from the BIS site and set my default to the address I want to keep; however, my BB will occasionaly try to send an email using the address I deleted.
    Last edited by zee921; 05-30-08 at 03:30 PM.
    05-30-08 03:12 PM
  21. chrislitzkow's Avatar
    I have the same problem. (And by the way- continuing to repeat "You should have seperate inbox icons" doesn't really do anyone any good.)

    This is an issue with people who have BES. If you don't use BES on your device, you probably won't understand the havok that the BES IT POLICY can wreak on your BlackBerry!

    I used to have seperate icons (inboxes) for my gmail, and my blackberry email accounts. HOWEVER- Now that I've activated BES, the ONLY inbox that shows up is the default "Messages" catch-all (the mailbox with a flag icon.)

    So far, I have not been able to find a way to seperate them, but would LOVE some legitimate advice. I think this is really something that is totally controlled by the IT POLICY that is sent to our device by whatever company we work for.

    FYI- have resent service books, and that doesn't work.

    Also, although I'm receiving gmail messages into the "Messages" inbox, I cannot reply to them! There literally is NO "REPLY" in my menu any more! I'm only able to reply to BES emails.

    So, anyone with any advice?

    Thanks!!
    07-22-08 03:43 PM
  22. Skwangie4's Avatar
    I had the same problem - two e-mails, one BES and one g-mail. I chose separate and my SMS/MMS messages got separated, but both e-mails stayed combined. I don't know why it worked, but I deleted my g-mail account and then set it up again while leaving the BES e-mail account alone, chose separate and they separated. Life is good again.
    08-26-08 05:13 PM
  23. Ezcal's Avatar
    I had the same problem - two e-mails, one BES and one g-mail. I chose separate and my SMS/MMS messages got separated, but both e-mails stayed combined. I don't know why it worked, but I deleted my g-mail account and then set it up again while leaving the BES e-mail account alone, chose separate and they separated. Life is good again.
    This worked for me. I don't have a BES account, but I deleted both my Yahoo! and school email accounts and re-added them. Now I've got two separate icons.
    04-02-10 08:53 PM
LINK TO POST COPIED TO CLIPBOARD