05-07-10 11:00 AM
35 12
tools
  1. jeffh's Avatar
    Saturday I upgraded the OS on my Verizon 8830 from 4.2.2.176 to 4.2.2.196. The upgrade appeared to complete successfully with no errors and no unexplained results. All my 3rd party apps restored successfully.

    Tuesday I made an edit to the Address Book on the blackberry. I added a new phone number to an existing address and pressed the escape key. At the prompt I clicked save. Instead of exiting after the save, the address remained on the screen. I thought I had simply mis-clicked, so I pressed the escape key again. This time I got an error message I had never seen before, and which a Google search failed to find in the forums. The message text says: "Address updated externally. Changes will be lost and the viewer closed." The only way out of the error was to click discard. The viewer did NOT close and the changes were NOT lost.

    Today I needed to delete an address from the blackberry. I selected the address and pressed delete. The address book closed and the screen displayed this error: "Uncaught exception: java.lang.IndexOutOfBoundsException." The contact was deleted from the database.

    A battery pull does not clear the error.
    Deleting the desktop sync service book, rebooting, and undeleting does not clear the error.
    Reregistering the Host Routing Table does not clear the error.

    The only change I have made to the blackberry is the OS upgrade, but I recognize the possibility that the problem is unrelated. I made the same memory optimizations per Stoner's procedure after the .196 was installed as I had previously made to the .176 OS.

    I called my IT support person. He was not familiar with the "Address Updated Externally..." error message. He said the java error would require a wipe and reload to fix. He offered to do the wipe remotely (I'm on BES), but I told him I'd wait until I could see if anyone in the forums had another idea.

    I don't have any problem doing a wipe and restore. All my important content is backed up on the Enterprise. My 3rd party software I can reload if necessary. I have the OS files for .196 and well as .176 and can roll back to .176 if necessary.

    Before I do the wipe and restore (sometime tomorrow, schedule permitting), does anyone have any suggestions?
    06-11-08 11:03 PM
  2. JRSCCivic98's Avatar
    Just wipe the Address Book database with DM (Backup/Restore/Advanced) and see if you can get it to push all your contacts back down. I don't know how BES would behave in a situation like this, but if you didn't have BES, I'd suggest you wipe the Address Book database and just resync with Outlook. If that didn't work, then it's most likely an issue with the java cleanup you did to free up memory. I've had no such issues with my OS load and I've made some edits of entries in AB.
    06-12-08 01:08 AM
  3. jeffh's Avatar
    Thanks. The Address Book database is grayed out on the Device Databases side of the screen. I assume that's because it's configured for wireless sync. I can copy it to the desktop database (which doesn't seem advisable, given there's an error with it), but I can't clear it using the desktop manager.

    Since I've never seen this error before, I feel sure it's something I did while upgrading. My IT tech didn't know of any problems using .196 with our BES, but they haven't pushed it to the users, either. It's just individuals updating on their own.

    Since I can't clear the AB database with my BES configuration, that would seem to leave me with only the wipe and restore option. Do you have any other suggestions? Or if I misunderstood you, please correct me. Thanks,
    06-12-08 09:07 AM
  4. JRSCCivic98's Avatar
    Reload the OS and leave it untouched. If it fixes the problem then you know it's not data corruption and a mistake you made while editing out the various cod loads. If not, then wipe. Go from there.
    06-12-08 10:26 PM
  5. jeffh's Avatar
    I downloaded and reloaded the OS and didn't tweak anything. Voice Activated Dialing and the Verizon theme reappeared on my menus. I had previously deleted those, so that's evidence that the newly downloaded and installed OS is indeed on the Blackberry. I did select the option to backup and restore apps and those all came back as expected. Checking the address book shows I still have the same error condition. Based on that, I believe a wipe and reinstall will be required.

    Thanks for your help and I'll post again when I get that done.
    06-13-08 09:24 AM
  6. jeffh's Avatar
    Backed up the device and wiped. When the Blackberry booted up, it prompted for my password. I tried to use the previous one. It was rejected because it was the same as the previous password. It seems passwords are stored somewhere that isn't reached by a wipe and scrub.

    I connected to the laptop, ran Desktop Manager and restored everything. The address book error is gone.

    My internet browser icon didn't come back until I re-registered the Host Routing Table. The BES Enterprise connection won't come back until the IT guy can re-register me in BES. When I talked to him, he said Rim had told them (my emp's IT Dept) that there was a bug in this OS that required it to be installed twice. I didn't argue with him, but that isn't consistent with your experience. Maybe it's an interaction with our BES. I don't know.

    I'm now performing the Enterprise Activation. When that's done, I'll go back into the OS and perform the memory optimizations again.

    Thanks for your help. This has been a good learning experience.
    06-13-08 10:56 AM
  7. jeffh's Avatar
    EA completed and I performed the exact same memory optimizations as before. And the exact same error condition with the address book recurred.

    I copied all the removed modules back into the OS directory and ran AL. It restored the modules. The device rebooted, but the address book error is persisting. I am now restoring the AB from the earlier backup. If that doesn't fix it, I guess I'm looking at another wipe and restore. Very puzzling.

    Restoring the backup didn't fix it.

    I removed themes I wasn't using, the password keeper, and the Voice Activated Dialing. The password keeper is small, and I had not previously removed it. So I'll try again and not remove it and see what happens.
    06-13-08 12:30 PM
  8. jeffh's Avatar
    Completed a second wipe and restore and Enterprise Activation. The corrupt Address Book error is persisting. I am no longer certain that I am causing this problem, but I don't know what else could be.

    If the only manifestation of the error is the problem I'm seeing with the address book, I can live with it until it's solved. Most of my AB editing is done on the computer anyway. But I'd really like to get to the bottom of this.
    06-13-08 03:19 PM
  9. Reed McLay's Avatar
    Humm....

    It sounds like the Uncaught Exception error has corrupted your Contact list.

    You will likley have a backup from prior to and during the .196 build. Try restoring it to correct the problem.
    06-13-08 03:57 PM
  10. jeffh's Avatar
    I have backups. And I have the .176 OS available to roll back to, as well. The second restore and enterprise activation also resulted in a bunch of duplicate emails in my bb messages folder, some of which aren't deletable. I know there's a thread here about that. The problem is, if I do anything that requires BES activation, it'll have to wait til Monday at this point. My bb is my only phone on weekends, so I can't risk disabling it.

    Is it necessary to wipe the device before rolling back to .176? If I wipe, I have to re-activate the Enterprise. If I don't have to wipe, I might try rolling back.
    Last edited by JeffH; 06-13-08 at 04:24 PM. Reason: Clarity: missing ? mark
    06-13-08 04:22 PM
  11. Reed McLay's Avatar
    There is no need to wipe the device, after you remove the .196 it will roll back with all settings intact.
    06-13-08 04:25 PM
  12. JRSCCivic98's Avatar
    Probably some wackyness with the new OS and your company's version of BES. Do you know if they are on the latest release. The good news is that if you roll back to .176 and you still have this problem, then you know it's some serious corruption of your address book database, if it goes away, then it was the OS. The weird thing is that you're the only one that's reported this as of yet and the OS has been out for at least a week.
    06-13-08 06:46 PM
  13. johnmccarron's Avatar
    I'd like to add that I get the same error when modifying a contact. I got it on my vz 8830 and then wound up switching to att 8820 and still get it. I am on 4.2.2.169. I don't recall what I was on with verizon but it was whatever the current os was 2 months ago. I use hosted exchange / bes. I am beginning to think that it is something in the contacts database b/c I have others on this exact platform, vzw & att who don't get the error.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-14-08 01:00 PM
  14. jeffh's Avatar
    That's helpful. Two months ago on Verizon, the 8830 OS was 4.2.2.176. The same version I just upgraded from. I never got these errors until I upgraded to 4.2.2.196. Later this weekend I'm going to roll-back to .176. I'm not sure what will happen if I install a backup older than what's on my enterprise server. I think doing that yesterday is the cause of the undeletable messages I now have.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-14-08 01:10 PM
  15. JRSCCivic98's Avatar
    Yes, don't restore an old backup. That will give you the undeletable messages you reported. Just do a current backup and restore that. Since you're on BES, if the corruption is in the address book, it's already too late and has propagated to the BES server. Your only hope now is that it's something with the OS that's causing this. Rolling back to .176 to check is your next step in troubleshooting. If the error goes away, then that was it. If it does not, then stay with .196 and have your IT BES guy figure it out. It's going to be on their end then. Going back to an old backup is not an option unless you restore everything from a current backup, then go back and delete just the address book and restore just that database from an older backup. Unfortunatly as you found out the other day, with BES integration you don't have these options on the backup/restore databases... which blows.
    06-14-08 02:00 PM
  16. jeffh's Avatar
    To summarize, your recommendation is
    1. Backup current system.
    2. Delete .196 and roll back to .176
    3. Restore from the current backup.

    Thanks for the confirmation re the old backups. I was pretty sure that was the cause of the undeletable messages. If I make a current backup now, won't that include the "undeletables?"

    My IT guy's only suggestion was rolling back to .176. They haven't pushed .196 and probably won't. He'll be as helpful as he can be, but debugging .196 is probably too much. As far as the error propagating to the enterprise, you're right there, too. I 909 contacts on the blackberry and 910 in Outlook. I haven't looked for the difference yet, but they matched before the errors started.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-14-08 02:18 PM
  17. jeffh's Avatar
    Results: I deleted 4.2.2.196 from my PC, did a battery pull, and plugged the BB into the USB. Windows found new hardware, as expected. I ran the Desktop Manager Applications Loader. It asked if I wanted to downgrade, I said yes, and told it to auto backup everything including messages.

    It completed successfully. I am now running 4.2.2.176 (Build 3.0.0.79). Since I had already optimized the memory load for this OS, I didn't have to do that again. My first file free reported 22 507 276 bytes free.

    Before I activated the Enterprise, I deleted the stuck email messages on my bb. Then I called my IT guy and reactivated my Enterprise. Everything came up, except for 5 new, different stuck email messages, and the address book would only sync one way, outlook to bb, not bb to outlook.

    I was able to clear the 5 new stuck emails using the process described in this thread: http://forums.crackberry.com/f33/can...-method-39978/

    I then deleted and re-sent my desktop sync according to the following steps, to try to fix the address book sync problem:

    1. Options/Advanced Options/Service Books
    2. Select the entry "Desktop [SYNC]"
    3. Push the Menu button
    4. Select Delete
    5. Answer "yes" to the "are you sure question?"
    6. Without turning off the blackberry, remove the battery
    7. Leave the battery out for a minute or so
    8. Put the battery back in
    9. After the blackberry boots up, select Options/Advanced Options/Service Books
    10. Push the Menu button
    11. Select Undelete


    I've used this procedure in the past to successfully restore OTA syncing. This time, though, after I ran through the steps, the corrupt Address Book error recurred.

    I've notified my IT guy that the problem is not specific to 4.2.2.196. Maybe upgrading to 4.2.2.196 caused it originally, I don't know, but I am now on 4.2.2.176 and still have the problem. I have not heard back from him yet. He's a nice guy, but he's probably taking two aspirin and wishing I'd go away!
    Last edited by JeffH; 06-16-08 at 09:41 PM. Reason: misspelled word
    06-16-08 01:30 PM
  18. JRSCCivic98's Avatar
    but he's probably taking two aspirin and wishing I'd go away!
    He's probably doing that because he doesn't know what he's doing. :lol:

    Well, the upgrade to .196 could have caused this issue, but unfortunatly the only way to test this would be for another person at your work to try the upgrade. I'd be more inclined to say the issue is probably with a BES server that's not on the latest BES version updates. Any clue as to what revision your BES is on?

    Either way, it sounds like you've done very thorough troubleshooting on your part. You're basically handing this all to the IT guy on a silver plater. He should be thankful you're not the average... "I tried to upgrade my OS and got this Java error on a white screen because it was taking too long to update and I had to run out the door, so I just unplugged it" user which we all just love.
    Last edited by JRSCCivic98; 06-16-08 at 05:46 PM.
    06-16-08 05:43 PM
  19. jeffh's Avatar
    ...the upgrade to .196 could have caused this issue, but unfortunatly the only way to test this would be for another person at your work to try the upgrade. I'd be more inclined to say the issue is probably with a BES server that's not on the latest BES version updates. Any clue as to what revision your BES is on?...
    Well, I can't in good conscience recommend anybody else try it, and I'd be surprised if my IT guy did...I asked him this morning about the BES version, and he said he couldn't tell me because he didn't know. I was a little surprised by that, he's the only Blackberry support person we have, or at least the only one I've dealt with under the current contract, and I just assumed he ran the BES.

    Our IT policy is very open, as you can tell since I am allowed to upgrade the OS. I'm concerned that if I cause too much trouble over the upgrade, that the easy solution will be to eliminate upgrades as a user option. They did that years ago on the PC side, so that we're all running XP SP2 with IE 6.0.29...not that I regret not having to deal with Vista!

    I'm not giving up, but I'm treading lightly. If any BES admins on the forum have any suggestions, such as a way I or he could fix the address book problem, please jump in. For now, I'm operational. The error is just a nuisance. I just have to be careful to make address book edits only on the Outlook side. I haven't found any other manifestations of the problem.

    It will be interesting to see what happens when Verizon starts shipping us 8830's with 4.2.2.196 or later as the factory load.
    06-16-08 10:08 PM
  20. JRSCCivic98's Avatar
    Well, I can't in good conscience recommend anybody else try it, and I'd be surprised if my IT guy did...I asked him this morning about the BES version, and he said he couldn't tell me because he didn't know. I was a little surprised by that, he's the only Blackberry support person we have, or at least the only one I've dealt with under the current contract, and I just assumed he ran the BES.
    There's your problem. BTW, as a side note, IE7 has been out long enough for support to be ironed out. There is no reason why you can't run XP SP2 w/IE7.
    06-17-08 03:17 PM
  21. jeffh's Avatar
    I found this in the Maintenance Scheduled Activities Log for May 17-18. Could it be a BES upgrade? There will be an upgrade from V3.3 to V3.4 for all BlackBerry Devices in the Americas by the Blackberry vendor. If it is, maybe it gives me the version number.

    I haven't heard anything from my IT guy. I may have to open a trouble ticket just to get it addressed, even though I probably won't like the answer.
    06-17-08 04:33 PM
  22. JRSCCivic98's Avatar
    Hey, check to see if you have any Groups setup in your address book. If you do, get rid of them and then see if the problem is still there after a battery pull once it's fully synced up contact wise. Give that a whirl.
    06-18-08 04:43 PM
  23. jeffh's Avatar
    No groups in the address book. I don't use that capability, but I just checked anyway. I have set them up In the past while helping a user on the forum, but I have none now. I use outlook categories instead.

    What did you think of the maintenance note re the May blackberry upgrade? That isn't likely to be my bes version, is it? BTW, my IT guy is off til Monday, so nothing more from him til then.

    Thanks for your help.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-18-08 04:51 PM
  24. JRSCCivic98's Avatar
    No, BES current version is like 4.0.5 SP2... or something along those lines. Don't quote me on it.
    06-18-08 05:17 PM
  25. jeffh's Avatar
    Hey, check to see if you have any Groups setup in your address book. If you do, get rid of them and then see if the problem is still there...
    My IT guy returned to work today with a suggestion that I turn in my 3-month old 8830 for a new one. I'm 800 miles away from the home office or I'd have been tempted to take him up on it. Instead I asked him to transfer the trouble ticket to IT support at my current location.

    The tech here took one look at it and said "that's caused by distribution lists in your blackberry address book. It's a known issue that Verizon and Rim are working, with no resolution at the moment." I thought you'd appreciate that, since you suggested it as a possible problem last week. The professionals are only a week behind you...

    Since you had already alerted me to that possible error condition, I was able to assure the tech that that was not the problem. After consultation with her lead tech, we all agreed for her to wipe my blackberry and restore my data from the BES server, without restoring any 3rd party apps.

    When I got the 8830 back, File Free showed 27 539 188 bytes free.

    I'm no longer getting the two error messages I was before.

    However, changes made to the address book are only syncing one way, from the PC to the BB. Changes made to the BB address book never show up in Outlook. Before the problems, contacts sync'd both ways.

    I tried turning off wireless sync, pulling the battery, and turning it back on. That did not help.

    I tried deleting the Desktop [SYNC] service book, pulling the battery, and undeleting the service book. That did not help.

    The tech here will do further research tomorrow. She also did not know the BES version, but assured me that it was the same here as at my home office, and that she could find out and tell me.

    I know the last 3rd party app I installed before the problems began. It was after I'd upgraded to 4.2.2.196. If we can get the address syncing bidirectionally again, I will upgrade to 4.2.2.196, wait a couple of days to be sure I'm stable, then install that app again and see what happens.

    As always, I welcome your thoughts and advice.
    06-23-08 09:16 PM
35 12
LINK TO POST COPIED TO CLIPBOARD