1. princealyy's Avatar
    Hey Guys... sorry for the dramatic title, but i neeeedd your help.

    I am in China.... and cannot get my international VZ 8830WE to work.. i have activated the international service with VZ and am able to make calls, in both CDMA and GPRS... but the email is not working.

    I have all my family contacting me from the BBerry (main reason we all converted to 8830's is so that we can be in contact via PIN's no matter where we travel)

    Please help me..

    Verizon told me that i do not need to unlock the phone since i am using the VZ Sim card...

    Any help will be more that appreciated...

    Thanks..

    BTW i am not calling Verizon, because ya'll always know better, and because i dont want to spend all that money calling them either...
    05-17-08 10:37 AM
  2. JRSCCivic98's Avatar
    Call VZW Global Support.
    05-17-08 11:04 AM
  3. hkmitsui's Avatar
    If you're using the verizon sim then you're gonna have to call global support in china. I'm trying to look for the number for you but i seem to have misplaced it. Theres a local number you call in china and it'll connect you back to the states. However, I was just in china and when I put another sim card in, it somehow connected to all my emails and messages. But good luck!!
    05-18-08 01:37 PM
  4. Javaddict's Avatar
    Any luck on this one yet guy? Did you end up having to call Verizon?
    05-18-08 02:05 PM
  5. Go Blue's Avatar
    Try making a manual service provider selection. I have found that when traveling internationally that the network selected automatically by the BB doesn't always work. It may work for voice, but often will not work for BB and/or data connection.

    I don't have a Verizon BB, so menu may be a bit different, and sometimes the menus are a bit different depending on the theme you are using, but .....

    Go to Options >> Mobile Network >> and you will see the list of networks available for you to use, and the one you are connected to will be highlighted.

    Try selecting a different network, and let it link and sync up with the new network. If necessary cycle through them all until you get a data / BB connection that works. That *may* be the issue you've got, often is for me and others whose BB's I have to set up to work when we land.

    Hope that helps. Let us know if you get connected and what it took to fix it. Expecting to get linked up when you walk off the plane, and finding that you can't is really frustrating, so hope it works out.
    05-18-08 04:01 PM
LINK TO POST COPIED TO CLIPBOARD