1. sortlane1's Avatar
    I am running the new OS 4.5.138 on Verizon and have a unique challenge with my gmail account. I have the account all set up and working fine. I can receive and read my gmail just fine on my bb.

    One challenge I am having though is if I read a gmail on my actual gmail account on-line it does not update on my phone as being opened - it still shows as unopened. I deleted and re-set up the gmail account. Reset the service books. All of this and still won't quite work right. Gmail updates the on-line account if I read it on my phone it just isn't working the other way around. My Outlook email is working good both ways so I am a little stumped. Any ideas on how to fix?
    05-02-09 05:43 PM
  2. matthew_i's Avatar
    I don't think BIS allows for two way sync for read messages like that. I have the same issue with my imap mail. You can install the gmail blackberry application from mobile.google.com which does do two way sync in addition to providing access to other gmail features.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-02-09 09:12 PM
  3. saintj's Avatar
    Try do the reconcile now option. That should do the trick......
    05-02-09 10:13 PM
  4. matthew_i's Avatar
    Selecting "Reconcile Now" does not appear to do anything on either one of my IMAP accounts. I tested deleting a message on the server and marking messages read on the server. I am on BIS.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-04-09 11:50 AM
  5. sortlane1's Avatar
    I tried the reconcile now as well which did nothing. Any different ideas other than running the gmail app?
    05-04-09 04:59 PM
  6. trucky's Avatar
    One plus for using the Gmail app is that you can close it when you choose to not receive email... can be nice at times.
    05-05-09 07:45 AM
  7. codemaker's Avatar
    I'm not sure about the reconcile thing. I tried it with my two IMAP accounts this morning, and the deleted messages on the server were also deleted on my phone. There was a bit of delay before the messages were deleted though. But now, it's not deleting a message that I deleted on the server. I also tested marking a message read (I don't know if that is supported anyway).

    I don't know why RIM does this on BES just fine but drops the ball on BIS like this.

    Update: The second test message just got deleted on the bb, but it took several hours. Other test message still marked as unread on bb.
    Last edited by codemaker; 06-30-09 at 03:58 PM.
    06-30-09 02:08 PM
LINK TO POST COPIED TO CLIPBOARD