1. pleasehelpphil's Avatar
    Hi,

    I have an unlocked blackberry 8800 and used it with a Fido data plan with no problems until last week when I updated my plan. Since the day I updated my data plan, my blackberry now displays the message: "Data connection refused" and all of my data applications have disappeared from my device. I tried the phone with another SIM card that had a data plan and the same problem persisted. I contacted Fido and they don't know what the problem is. Does anyone know how I can fix my phone?

    Thanks,
    Phil
    01-14-08 06:08 PM
  2. John Clark's Avatar
    Data connection refused means you don't have a connection to the RIM data servers. (no BB data plan.)

    Call Fido and ask them to enable a "Blackberry Connect" data plan.
    01-14-08 11:19 PM
  3. pleasehelpphil's Avatar
    Thanks John. I called fido and they said that if i reconfigured my phone it should work. They gave me a GPRS asn, username and password and a WAP asn, username and password. Where do I go in my phone to put in this info?
    01-15-08 08:47 AM
  4. John Clark's Avatar
    I doubt that will get rid of the data connection refused message.

    You put it in Options >Advanced Options >TCP
    01-15-08 10:59 AM
  5. techsupportlowrong's Avatar
    A "data connection refused" error is usually an indicator of errors in programming or errors on the account at, in your case, fido. they may have the wrong device code in your account, or, sometimes when you update a package or plan, the programming on your bb needs to be redone.
    you should have the programming rechecked, the probable errors are: network code, country code, registration id, mo voice so home, mo voice so roam, mt voice so home and mip user id being incorrect. you can either bring it to a dealer to have it reprogrammed or call fido and they can walk you though it.
    once the programming is checked and once its correct you should have you icons back.
    if that doesn't get them back then go into options:advanced:host routing tables and click the (track wheel/menu button, not exactly sure on this version) then it will show you an option for register now, click that, a registration message will be sent to your bb. open that and it will say something along the lines of "congradulations, you have not been registered with the (carrier name here) wireless network blah blah blah and then when you read through the whole thing your icons will pop up...
    now, if after all that they still dont, hold down the alt button and track wheel at the same time and go to show all, but this will only work after programming and registering with the wireless network
    02-04-08 10:50 AM
  6. Adlen's Avatar
    When I re-issued my BlackBerry plan I had to reboot my BB. Try a battery pull.
    02-04-08 04:02 PM
  7. techsupportlowrong's Avatar
    thats a good idea as well but to power cycle the bb correctly you have to leave the bb on while doing so, so dont shut it off before taking the battery out or it doesnt really do anything.
    good luck mate.
    02-05-08 09:49 AM
  8. Wolfmaan's Avatar
    I called fido over the issue myself. They advised me of the following:

    Fido APN: wap.fido.ca
    FIDO Unsername: FIDO

    After doing that, it still stated "Data Connection Refused"

    Removed the battery while the phone is on, then rebooted - same thing, still not working properly.
    02-27-08 12:12 PM
  9. John Clark's Avatar
    Call Fido and ask them to add the Blackberry Connect plan. That's what you need for Fido.
    02-27-08 12:16 PM
  10. msblueline's Avatar
    I agree, you some how have lost your blackberry plan. I will say that I have changed my service before and had a lock out. I had to call blackberry and have them reset my service to accept the new service plan. I am with AT&T and if I am correct...again. They have their own data support team. Blackberry will not talk to me. I have to call AT&T. You might want to call "fido" is it, sorry if I messed the name up. Just tell them that you don't have a Blackberry plan. They will look at your account and then tell you wether it is configurd correctly or not.

    msblueline
    03-04-08 10:54 PM
LINK TO POST COPIED TO CLIPBOARD