1. radar-man's Avatar
    I have seen a few posts on this problem, but no solution so I thought I would post this to see if there is any new informaiton.

    I recently updated my BB 8830 WE to OS V4.5.0 (release 177). This is the very latest release of OSV4.5 available. This upgrade caused problems with my BB - after the upgrade, the BB would not charge either with the external charger or the USB link to my computer. I downgraded the OS back to V4.2 and the phone charger worked fine again.

    To be sure it was the upgrade that caused the problem, I reinstalled OS V4.5 - charging no longer worked, then downgraded a second time to V4.2. After the downgrade, the charging worked fine again. So I have confirmed this is NOT a hardware problem, but instead it is a software OS problem.

    I would really like to upgrade my phone to V4.5.0 because I like the software interface, but obviously I cannot upgrade since I can no longer charge the phone after I do this.

    Is there any way to upgrade to OS V4.5.0 and fix the charging problem?
    02-23-10 11:26 AM
  2. iBlack11's Avatar
    Wait for the next release.
    02-23-10 04:33 PM
  3. radar-man's Avatar
    At the rate I see releases coming out, I may be eligible for a new BB upgrade by then. I have sent the info on the bug to Bell (my carrier) and RIM - we shall see what comes of it. I'll post any updates I receive from them.
    02-23-10 09:28 PM
  4. radar-man's Avatar
    Wow - this forum is just so helpful!
    02-24-10 05:11 PM
  5. mitchknowsbest's Avatar
    Lol. I had a similar problem. I use the 8820 and I updated my os to 4.5.0.187 and after that my charging time takes alot longer. I have to wait around 10 to 15 mins to see the charging change from 50 to 52 or 54%. It was faster using 4.2. I guess mine does charge so i'll keep 4.5. Good luck.
    02-24-10 08:41 PM
  6. radar-man's Avatar
    Got a reply from Bell Technical Services - essentially "too bad, so sad" reply. They can't determine the problem, and I would have to pay to have the phone fixed. Seems that my version 8830 (and apparently many many others) may have a firmware/hard problem that prevents V4.5 from working properly. Guess I WILL have to wait for a new OS or, more probably, when I am eligible for an upgrade to my phone.
    02-25-10 09:37 PM
  7. mitchknowsbest's Avatar
    So I guess it wasn't the berry but the charger. I used my 8700G charger and it charges in an hours time. I tried the charger for my 8820 on my 8700 and it would take hours to charge it. Lol I was about to kill my poor berry and get a new battery too.

    Posted from my CrackBerry at wapforums.crackberry.com
    02-26-10 09:25 AM
  8. radar-man's Avatar
    Perhahs I should qualify. Bell doesn't know what the problem is, but it isn't the charger because I have used three or four different ones. It is likely a problem with the charging circuit inside the Berry.

    In any case, I have a solution!!! Amazon sells an external battery charger for the 8830. Only $10. So, I can charge my phone and still upgrade to V4.5. Awesome!
    02-27-10 12:05 PM
  9. radar-man's Avatar
    OK - get this.

    As I suggested above, I switched to an external charger for my battery a while ago. Tres inconvenient, but there it is - I'm not elidible for an upgrade until early 2011, so I'll be patient until then.

    I noticed last night that there was an OS release 4.5.0.186 available for the WE (I had installed .127 when my problem started). Low and behold, when I plugged the WE into my computer, the damn thing started charging. I then tried my USB charger, and it also charged the BB.

    So, stupidly, I installed V.186 on my WE - and now I am back to not being able to charge again. The charging stopped as soon as I rebooted my blackberry after the reinstall.

    When the problem happened before, I spent several hours on the phone with Bell Tech support - they couldn't explain the problem.

    I have spent enough time on this problem, and I plan to upgrade soon, but this problem is so mind boggling stupidso I wonder if someone could explain it.
    09-10-10 09:38 AM
  10. J-sin-89XX's Avatar
    i havent seen the same issues, but i feel your pain. i busted the charge port on an 8800 and had very few options to go to a diferent phone at the time. I utilized a charge stand for mine and was curious if that might help with the charging part of your issue. it just connects to the brass points on the side of the phone. for me, it work and i just used wireless sync to connect to my pc.
    09-10-10 10:27 AM
  11. radar-man's Avatar
    Cool - a charging stand would definately be more convenient. I can't see myself investing any more $$$ into this phone, but I think I'll try the charging port by two wires from my battery charger to the brass points. I am just curious to see if it works. Anyone know the polarity of those posts (i.e., where should I connect positive)?
    09-10-10 11:40 AM
  12. attroll's Avatar
    I have the same issue after upgrading my 8530 to v5.0.0.886. I don't know what to do to fix this.
    09-13-10 09:02 PM
  13. radar-man's Avatar
    Looks like a charging stand wouldn't work for me. I tried charging via the two brass/gold contacts on the side of the BB, and no dice. It seems like the internal charging mechanism is disabled by the software. By the way - downgrading back to OS4.2 will allow me to charge again, but I have gotten used to OS4.5 and don't really want to go back.

    To Attroll - perhaps the only way to fix yours is to downgrade your OS to the old you had previously. There are several threads here that give instructions on how to do this.
    09-18-10 12:08 PM
LINK TO POST COPIED TO CLIPBOARD