1. lawman218's Avatar
    I have a verizon 8830 world phone am I able to download I heart radio to it. THX
    Last edited by lawman218; 04-19-09 at 07:46 PM.
    04-19-09 07:43 PM
  2. FF22's Avatar
    I did - no problem but I have OS 4.5 although I don't know if that is needed - just full disclosure.
    04-19-09 08:24 PM
  3. saintj's Avatar
    YEs 4.5 is needed
    04-19-09 09:40 PM
  4. mconk's Avatar
    Lawman...is your first name Josh by any chance?

    Posted from my CrackBerry at wapforums.crackberry.com
    04-19-09 10:15 PM
  5. wallpaperguy's Avatar
    I think Iheart is compatible with 4.3 or higher

    Posted from my CrackBerry at wapforums.crackberry.com
    04-19-09 10:36 PM
  6. wolfshadow's Avatar
    How did you download iheart to a BB 8830 WE? The website says that the 8830 is not supported and will not take me to a download link.
    04-20-09 09:52 AM
  7. mconk's Avatar
    According to the FAQ on iheartradio.com, the 8830 is not yet supported, and the website will not allow you to dl this app. However, I noticed a few weeks ago when I installed App World, I was able to dl and run this app sucussfully through App World. My local stations weren't there so I ditched it. Also ditched App World as its much simpler just to come here.

    Michael

    Posted from my CrackBerry at wapforums.crackberry.com
    04-20-09 11:54 AM
  8. lawman218's Avatar
    no not josh sorry
    04-20-09 07:14 PM
LINK TO POST COPIED TO CLIPBOARD