1. jarbeaub's Avatar
    I bought an 8830 we off ebay. When i got it the scroll wheel was missing, but i thought i can just get one. when i put the battery from my 8330 in it, it didnt do anything besides the red led flashed and stopped. after much reading here and other forums, i tried to reinstall the os. after it erased all apps, it installed os i believe, then rebooted. after which the screen lit up. I thought i had it going, but it showed a battery with a red slash through it, and cannot reconnect to the device no matter what i try. I will trash the thing, but i thought someone might have some ideas as to what else i can try. i have tried dos boot, tried apploader and to no avail. nothing seems to work. thanks for your help. jarbeaub
    07-31-10 11:52 PM
  2. coolkenny13's Avatar
    i think you clearly got ripped off from ebay . never buy old devices from there again .
    08-01-10 01:55 AM
  3. jarbeaub's Avatar
    thanks for the sarcasm< but i clearly didnt get any help from dont buy its a rip off. Just in short< Help or move on> dont need people being smart here... if u dont know, then you dont know. My device connects unknown usb pin but cannot reconnect to the device after loading the os. there has to be a way to fix it... it isnt totaly dead is it? i even tried to drop it, tap it on the back.... it has a cs2 battery instead of a cx2 battery and after much debate, i think the cx2 has 4 or 500 mAh more, but it depends on whom you ask. does the battery make that much of a difference??
    can someone try an experiment using a cs2 battery in an 8830 we and let me know?????? thanks, Jarbeaub
    08-15-10 06:33 PM
  4. jarbeaub's Avatar
    08-01-2010, 01:55 AM
    coolkenny13
    CrackBerry User Join Date: Aug 2010
    Posts: 12



    --------------------------------------------------------------------------------

    i think you clearly got ripped off from ebay . never buy old devices from there again .

    Wow, i realy thought there were smarter people than that here.... as it turns out, the battery IS the big problem here. yes the cs2 battery seems to power the 8830, However the battery isnt powerful enough. I got the new battery today, and put it in and guess what happened????? yes the 8830 WE is up and running again. THANKS to another site that sugested it might be the problem.
    08-17-10 06:57 PM
LINK TO POST COPIED TO CLIPBOARD