1. simplewilliamz's Avatar
    I was using my bb 5days ago and the battery was low, I plugged it into an power outlet and turned it off to charge. The battery charging symbol was on display. And after 30mins I found it restarting, ever since then it has been restarting. I got two new batteries but it still does the same. I tried the batteries on another device and it powered it. Dunno what else to do

    Posted from my CrackBerry at wapforums.crackberry.com
    12-04-10 09:03 AM
  2. jeffh's Avatar
    I had something similar happen with my 9630. The battery is old and won't hold much charge anymore. I accidentally used it until the phone shut down. I put it on the charger and when the battery recharged a little, the phone tried to turn on, but the start-up load dropped the battery voltage too much and the phone shut down again. The solution is to put a fully charged battery in the phone.
    12-11-10 04:55 PM
  3. txbell's Avatar
    Go to options, security options, memory cleaning and enable it. This worked for me on my bb 8830.
    01-22-11 08:11 AM
  4. jeffh's Avatar
    I don't understand how memory cleaning (a security function) could solve the OP's problem, which appears to be a battery issue. Can you elaborate on your symptoms?
    01-22-11 08:45 AM
  5. txbell's Avatar
    I had the same problem that simple williamz had, and this, plus a log clean (alt-lglg) seemed to resolve everything. Please note you have to do both on a fairly regular basis once you start to approach your device memory limit. 64 mb of memory is extremely limiting.
    01-23-11 10:33 PM
LINK TO POST COPIED TO CLIPBOARD