1. dtone#CB's Avatar
    Being a newbie to blackberry, my smartphone will not allow me to download "Blackberry apps". I get the message " Sorry, your device does not meet the system requirements that are needed to support BlackBerry App World." Any ideas on how to change my system requirements?
    11-10-09 02:13 AM
  2. Terry K's Avatar
    You'll want to upgrade the OS on the phone. The current version should be a 4.5 variant. If it has a version older than that you'll need to upgrade it via desktop manager.
    11-10-09 03:38 AM
  3. dtone#CB's Avatar
    Thanks to all for the replies. I have done some investigating and found that the system is current, however their are "IT" restrictions on the phone so I guess I will have to "wipe" the phone.
    11-11-09 01:31 AM
  4. MousePad's Avatar
    You can't!

    These IT restrictions are called an IT Policy. There are ways to remove such IT Policies from a BB, but since your device is issued by your employer, it's probably connected to a BES.

    The minute you reactivate it on the BES, the IT Policy will be pushed again to your device, restricting you again from downloading all kinds of fun and interesting stuff..
    11-11-09 07:32 AM
  5. 312's Avatar
    Wrong forum. This is 8830 WE, not 8330.
    11-13-09 11:36 AM
LINK TO POST COPIED TO CLIPBOARD