1. sengokubattosai's Avatar
    The only problem I have with the 8703e is the lack of volume!!!! I have ALL of my alerts set on high volume and I can barely hear them in normal surroundings! And it does not help that you cannot set it to vibrate WHILE ringing like on any other phone, rather it vibrates before ringing 5 seconds later! Is there any way to change this? Because this is going to get old really fast if I keep missing calls/messages because I cannot hear them on the highest volume setting!
    03-30-09 10:03 PM
  2. Michael Hepples's Avatar
    Have you tried changing the ringer profile to ring only? If you go into the Profiles, and edit the one you normally use, there should be an option to set to ringer only, with no vibration.

    Forgive me if the info isn't that specific, but it's been a while since I traded in my trusty 8703e.
    03-30-09 10:07 PM
  3. sengokubattosai's Avatar
    Yeah, I've done that, I just wish it would either vib and ring simultaneously or ring louder... I don't know if there is anything I can do though...
    03-30-09 11:22 PM
  4. chustle925's Avatar
    Rim doesn't allow their devices to vibe and ring at the same time, you need to download an app called buzzme, which will allow your phone to do this.
    11-08-09 10:58 AM
LINK TO POST COPIED TO CLIPBOARD