1. scotchonrocks's Avatar
    My operator is 3 in Australia. I need to reload the OS due to a corrupted browser file. Reading through posts on here I find comments about downloading the OS from 'your operators site'. Well 3 in Australia do not let you download anything from their site.

    I am wondering if I load the OS from another operator, whether it would allow my phone to work with my carrier. If so, can someone point me to a download site where I can do a download and get my phone operational again. My alternative is to wait a long time while my operator fixes my phone at great cost and waiting time to me.
    01-24-09 10:48 AM
  2. Heresy's Avatar
    https://www.blackberry.com/Downloads/browseSoftware.do This is for your 8707g on 3 Austrialia.
    Select your device and download. As far as using another providers OS, yes you can do it you would just have to delete the vendor.xml file. Follow the link in my signature for proper upgrade/downgrade instructions.
    Last edited by rlp32; 01-24-09 at 12:52 PM.
    01-24-09 12:48 PM
  3. scotchonrocks's Avatar
    Thanks. However the link to the 3 Australia software is dead.

    I get the following message at that URL

    Quote:-

    We're Sorry...

    You've entered this page in error because you have the incorrect link.

    Please make sure that you have the correct link to download BlackBerry software.

    If you have any questions, please contact the webmaster.
    01-25-09 07:31 AM
  4. Heresy's Avatar
    http://forums.crackberry.com/f6/newe...2-122-a-18400/
    This will work for you. Just follow the directions and you'll be good to go.Whats funny is I can go to that link for 3 Austrailia and download it. Wonder whats going on.
    01-25-09 11:15 AM
  5. scotchonrocks's Avatar
    Now I'm in a bind. I think my 8707g is bricked/nuked/wiped or whatever. Anyway I get a screen I've never seen before and nothing else.

    I used CrackMem to do a wipe of the old OS. Then tried to load the OS without success. I went to the forum for fixing a 'nuked' BB.

    First went to the open directory at c:\Program Files\Common Files\Research In Motion\App Loader then clicked the file 'LOADER' then clicked Next and thats where it all seems to go pear-shaped. Is there a set of files that should appear on the application loader wizard screen. Mine does not have any. I don't have a clue how to get out of this mess. Please help.
    01-26-09 01:11 AM
  6. dlui's Avatar
    Is there a set of files that should appear on the application loader wizard screen. Mine does not have any. I don't have a clue how to get out of this mess. Please help.
    What operating system are you using? XP or Vista?

    If you use Vista, then make sure to open Loader.exe as Administrator.

    If XP, then make sure you've properly installed the BB OS that you want reloaded.
    01-26-09 12:33 PM
  7. scotchonrocks's Avatar
    I'm running XP.

    Not sure what's wrong. I don't know how to confirm if I have installed the sftware (on the PC) correctly.

    However, I re-installed on another 8708g today and it was fine, ut when I connect the 3 Australia handset the software does not show up on the screen of the interface as it did with the other install. Wierd - but how to find out whats going wrong?
    01-27-09 07:15 AM
  8. Heresy's Avatar
    Ok unistall all your OS. For both 8700 phones. Do this by going to control panel then add remove programs. That how you check if its installed by the way. Then install the OS you need again. Go back to add remove programs and comfirm that there is 2 blackberry entries. 1 for desktop manager and 1 for your phone. Right here I would reboot your pc. Now go delete the vendor .xml file again. Start DM and plug in your device. It should prompt you for the install. If not go to the app loader and browse and select it should be good from there. One more thing. Don't use your computer for anything else other than the install while its running. Don't let the screen saver come on either.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-27-09 02:24 PM
  9. john dagis's Avatar
    I tried that link you gave, and it doesn't work for me either. I'm also in Australia
    01-28-09 01:59 AM
  10. scotchonrocks's Avatar
    Ok thanks - I'm working on the fix now.

    One thing though. I still could not access that link provided. However my friend in the Netherlands was able to see it. It is a Singapore Telecom OS. Will this be OK in my phone? I note the deletion of the vendor.xml file which probably renders this OS acceptable. Am I correct?
    01-28-09 04:23 AM
  11. Heresy's Avatar
    Yes your correct it will work. The OS's are device specific. I do this all the time as I usually run beta OS's. IF you have questions or need some help during the day feel free to email me at rlp32@crackberry.com I will try to help you out as best I can.
    01-28-09 07:41 AM
  12. scotchonrocks's Avatar
    Got it all working and thanks a million rlp32.

    It's not an easy road, but without your help, it would not have been possible for me I doubt. Saved me a ton of time sending my BB back for re-installation by the operator who are a bit difficult to deal with and would burn up time.

    Thanks so much!
    (Just getting into this BB business, so no doubt will be in touch in the future so thanks for the gesture and email address)
    01-28-09 06:43 PM
  13. Heresy's Avatar
    Hey not a problem scotch. All you owe me is a scotch on the rocks some day. Feel free to email me anytime you need help, thats wht I'm her for.
    01-29-09 06:27 PM
LINK TO POST COPIED TO CLIPBOARD