1. Zhan's Avatar
    Hi, I just bought a used 8700c from ebay. It is functioning well but the os is still 4.1.377, so I tried to upgraded it to 4.2. I am using DM 4.2 sp1 and the rom is a 4.2 rom from ATT.

    When I tried to load the os to the phone, it stopped at the first step connect to the device rom/connecting to boot rom. The phone will not be connected and an error message with appear without defined error cause.

    I wiped all the software on the bb and tried to do it all over again. The problem still exists. I tried DM 4.2, 4.3, 4.2 rom, 4.1 rom, 4.5 rom and 4.2 rom from different carrier, but I cannot fix it.

    Now, there is a 507 sign on the screen and I cannot load any os.

    Can anyone help me with this. Highly appreciate.
    04-23-09 12:07 AM
  2. sunkast's Avatar
    Error 507 means there is no OS present on the device. Are you connecting through a USB hub? That can be an issue. What version of Windows are you running? What happens if you try to load the OS now?
    04-23-09 01:17 AM
  3. Zhan's Avatar
    I am using windows xp and I am using a usb cord to connect my 8700c to my computer. 507 means there is no os loaded, and I have been dealing with this problem a lot of times before. Even though the bb is not connected as indicated by the DM, I can still forcefully load a new os.

    This time, it is different, I can initiate loading, find the rom, select the items I want to load, and when I clicked finish to load, it stops when it tries to connect to boot rom and cannot continue.

    I tried it just now and the same problem exists
    04-23-09 09:39 AM
  4. sunkast's Avatar
    Try taking the battery out before you begin. After Desktop Manager connects to the boot rom you can put the battery back in. If you don't put it back in before it restarts it won't load the OS.
    04-23-09 02:01 PM