08-15-09 11:01 AM
39 12
tools
  1. clexman's Avatar
    I searched everywhere for os 4.5 for my 8703e and no one had any links or info. I went to blackberry.com - software - and device software, and loaded it on no problem.

    Is this new? or does everyone already know its available?

    Sprint 8703e with os 4.5

    I would have posted a link, but I cant until i hit 10 posts
    Last edited by clexman; 05-21-09 at 05:12 PM. Reason: Title change
    05-21-09 03:17 PM
  2. clexman's Avatar
    I'm checking things out, but its painfully slow. I'm seeing the hourglass a whole lot
    05-21-09 03:27 PM
  3. skynny70's Avatar
    Didn't Verizon "fail" the 4.5 OS for the 8703e? T-mobile approved it as Kevin posted today in the blog section. Maybe the troubles you are experiencing are why Verizon has not released it?
    05-21-09 03:32 PM
  4. D2G's Avatar
    This is posted on BlackBerry.com?
    05-21-09 03:34 PM
  5. clexman's Avatar
    This is posted on BlackBerry.com?
    Yes,
    Go to blackberry.com and click on the "SOFTWARE" tab at the top, then "BlackBerry Device Software" on the left, and click the big "Update Now" button.
    The application loader software gets installed, connect your 8703e via USB and it gave me the choice of downgrading to an earlier 4.2 build or upgrading to 4.5.
    05-21-09 03:41 PM
  6. clexman's Avatar
    I think it just needed to be running for a little while to speed up. Now that I've run all the applications at least once, it moves along just as fast or faster than os 4.2 and the menu & text styling makes it look like I upgraded to a higher resolution screen.

    I had to re-install the Facebook app
    05-21-09 04:56 PM
  7. gotnoteeth's Avatar
    I'm checking things out, but its painfully slow. I'm seeing the hourglass a whole lot
    What is painfully slow?
    05-21-09 04:57 PM
  8. clexman's Avatar
    What is painfully slow?
    At first it took about 2 minutes for the media app to show the pictures. Now it opens right away. Viewing a slideshow was more of a spinning hourglass show. There was a long pause to view emails or reply to a txt message. Just clicking on the applications icon from the home screen was giving a 5 second delay and a spinning hourglass.

    No complaints anymore though. Its great now.

    Text looks a lot clearer everywhere. Much easier to read.
    05-21-09 05:08 PM
  9. D2G's Avatar
    Found it - thanks! I look forward to doing this upgrade tomorrow! We'll see if I experience the slowness at first too.... Definitely doing a back-up first.

    Edit update: Just ran the updater as you described clexman and the software states that my 8703e is up-to-date running on OS 4.2.1.110. Not available for VZW users I am guessing due to the "fail".
    Last edited by D2G; 05-21-09 at 08:21 PM.
    05-21-09 07:59 PM
  10. ObliteRon's Avatar
    Wow, thanks for pointing this out.

    Here's a link to Sprint's 8703e support page. From there, the "Check for Updates" link will bring you to the info about OS 4.5:
    Support - BlackBerry 8703e
    05-22-09 01:02 AM
  11. D2G's Avatar
    Wow, thanks for pointing this out.

    Here's a link to Sprint's 8703e support page. From there, the "Check for Updates" link will bring you to the info about OS 4.5:
    Support - BlackBerry 8703e
    Got OS 4.5 from the above link to easily work on my VZW 8703e. Just delete the vendor.xml file and update. As clexman reported, I did get the hourglass quite a bit on the first few boots after the install. But after a few battery pulls and reboots, it works just as fast under OS 4.2.
    Last edited by D2G; 05-22-09 at 11:55 AM. Reason: Attach picture.
    05-22-09 11:52 AM
  12. clexman's Avatar
    I'm loving the HTML email finally! It took me a bit to realize that I had to resend the service books for it to work though.

    Call me out of date for using the 8703e still, but I'm out of contract with Sprint and patiently waiting for a Blackberry worthy of an upgrade.

    The only thing still missing is the ability to use the app world.
    05-22-09 12:00 PM
  13. D2G's Avatar
    Yes, HTML email is great! Overall the UI in seems to be more polished and the phone boots up a lot quicker from a battery pull than under OS 4.2. Still having some issues getting the bluetooth to sync properly with my Infiniti hands-free system, it worked perfectly under OS 4.2.
    Last edited by D2G; 05-22-09 at 04:12 PM.
    05-22-09 04:04 PM
  14. gotnoteeth's Avatar
    It is incredibly slow at first, but like others reported it does get faster.
    05-22-09 08:38 PM
  15. ircactus#CB's Avatar
    Thanks for the links. I still have a few people running 8703e's. Updated without issue. Thanks again
    05-22-09 11:54 PM
  16. Pamelafend's Avatar
    Thanks for the review! I want to say - thank you for this!
    05-23-09 11:20 AM
  17. starmsmac's Avatar
    I also upgraded to the 4.5 OS. I also updated my AIM, but it won't run, I get the message " not enabled for this device". Anyone got solutions or is back to the old AIM?
    05-23-09 12:51 PM
  18. D2G's Avatar
    I also upgraded to the 4.5 OS. I also updated my AIM, but it won't run, I get the message " not enabled for this device". Anyone got solutions or is back to the old AIM?
    You need the AIM service books. Go resend the service books from Sprint's BIS website.
    05-23-09 01:49 PM
  19. starmsmac's Avatar
    I tried sending the service books, did not work. deleted and re-installed, still did not work. tried the provisioning thing, did not work.
    05-23-09 03:21 PM
  20. D2G's Avatar
    Aside from pointing your BB's browser to www.blackberry.com/aim to download the latest AIM app and then having service books sent, not sure what else is the problem.
    05-23-09 06:26 PM
  21. starmsmac's Avatar
    I tried a whole bunch of things.. just not working for some foggy reason.
    05-23-09 08:54 PM
  22. gotnoteeth's Avatar
    Has anybody else noticed the selector disappears when you scroll down quickly? You have to go back up and find it for it to work again.

    I am talking about the one used to follow links in view mode, not to select text.

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by gotnoteeth; 05-23-09 at 11:04 PM.
    05-23-09 11:02 PM
  23. D2G's Avatar
    Has anybody else noticed the selector disappears when you scroll down quickly? You have to go back up and find it for it to work again.

    I am talking about the one used to follow links in view mode, not to select text.

    Posted from my CrackBerry at wapforums.crackberry.com
    Yes, I remember something like this happening to me right in the beginning after first installing the OS and I was like WTF. Haven't had any issues and I just tried to replicate the same effect now and couldn't. Could you give a specific instance where this problem occurs?
    05-24-09 09:17 AM
  24. gotnoteeth's Avatar
    It is easy to duplicate. Start at the top of the page and quickly scroll down. The selector will disappear. You need to scroll back up to find where it stopped to get it back. It really is making my BB a pain to use.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-24-09 01:18 PM
  25. njhorvath's Avatar
    I updated today, resent my service books and still no MMS.
    My media player is incredibly slow. Been waiting for this since March and am starting to regret the upgrade
    05-24-09 06:55 PM
39 12
LINK TO POST COPIED TO CLIPBOARD