1. markd951's Avatar
    I am using the messages feature to send text messages to friends. For a while now I have noticed that I frequently get a "Pending" status on texts that I attempt to send out. In order for the messages to go out I have to turn off my wireless, turn it back on and then go into messages and resend...and it works 50% of the time. Anyone have an idea of what is going on? I tried upgrading my device software to 4.2 and when that didn't work, I performed a wipe of the blackberry thinking some type of setting or software I had installed was causing the issue. Thanks for any help you can provide!
    12-12-07 10:01 AM
  2. coolwhipdefuser's Avatar
    I've noticed that it takes a while for some messages to send. Is this performance restricted to when you are in particular areas, or are you getting it everywhere in your local coverage area? At the time you are sending the message, are you showing a signal/data connection?

    Honestly, I don't think its necessarily a problem with your device, it sounds more like a coverage problem. Let me know about those questions I asked and I'll see if I can offer any more suggestions.
    12-13-07 12:11 AM
  3. markd951's Avatar
    I've noticed that it takes a while for some messages to send. Is this performance restricted to when you are in particular areas, or are you getting it everywhere in your local coverage area?

    ANSWER: Everywhere in my local coverage area I am having this issue. In fact I noticed that I have to repeat the same steps to make a call.

    At the time you are sending the message, are you showing a signal/data connection?

    ANSWER: Yeah I have a full signal and I don't see the data connection arrows until it sends. One thing I did notice the delay is like 10 minutes for a text. The whole call issue I end up performing my "turn off wireless, turn on wireless" steps so I can make a call. It only seems to affect me if my phone is not used for a while. If some calls me or text messages me, I can call back or respond immediately. It is really strange.

    Honestly, I don't think its necessarily a problem with your device, it sounds more like a coverage problem. Let me know about those questions I asked and I'll see if I can offer any more suggestions.

    Thanks
    12-14-07 03:19 PM
  4. DiverSpear's Avatar
    Go under "options", "SMS Text", and you will see delivery period make sure it is set to Immediate.

    I don't know what to say about the call issue.
    12-29-07 10:24 AM
  5. markd951's Avatar
    Thanks for the tip Diver, tried that too and it was set to immediate. A couple of days ago my BB completely crashed for no reason. I called Verizon and explained the issue. Turns out there is an issue with my phone and they sent a replacement. I received the replacement yesterday and I have already noticed a dramatic difference, messages go out immediately and calls have no problem. The only thing I could see with sending this back is them saying either physical or water damage now (which is BS, never touched water or been beat around, I baby this thing). The indicator at the bottom of the battery door is partial red and the battery itself reports no damage so this should be interesting to see what they say. I ended up taking pictures of the old BB and the two patches in case there is a conflict.
    Last edited by markd951; 01-04-08 at 07:39 AM. Reason: more notes and spelling corrections
    01-04-08 07:37 AM
LINK TO POST COPIED TO CLIPBOARD