1. Titanbry77's Avatar
    Hello all, I have not seen this problem before but I have a few Bberry 8700C's and I have one that was practically brand new when i bought from a company that went out of biz. It was locked and had their IT policy on it which I removed but no matter what SIM card I put in, it still does not recognize the SIM card.

    I tried multiple sim's from other Bberry's and just standard GSM phones, its Cingular and thats what we run. Could they have had another policy or somthing on it to block SIM's etc that I missed?

    Thanks in advance.
    10-12-07 08:41 AM
  2. rrrebo's Avatar
    I don't see why they would block SIMs, unless perhaps they did not want any phone functionality for their employees. Have you tried wiping the device yet?
    10-12-07 08:50 AM
  3. Titanbry77's Avatar
    Yes Sorry i meant to put that I did a total wipe, then i installed the most current Bberry OS for that phone.. 4.2 and still nothing. It boots up, does the verifying security thing, then under my ATT logo it says "Insert Sim Card" and in the top right next to the antenna icon.. "SOS"
    10-12-07 09:06 AM
  4. rrrebo's Avatar
    Could be a bad SIM slot. Probably need to take it in.
    10-12-07 10:00 AM
  5. Titanbry77's Avatar
    Ruh roh... do you know if this is somthing that happens often? I may take it to cingular, im sure they wont do much seeing how i didnt buy it from them but ill leave that out, seeing how i have 22+ active phones with em.

    I won't want to spend too much on it, otherwise id just buy a new one.
    10-12-07 12:14 PM
  6. rrrebo's Avatar
    Ah, that's right, you bought it from a now-EOL biz. You might could send it off to RIM and see what they, or just get another from eBay.
    10-12-07 01:01 PM
  7. Berryman's Avatar
    Insert SIM - SOS Only is the message you would get if during the unlocking process the Blackberry did not have a valid SIM inserted. Could that be true?
    Last edited by Berryman; 10-13-07 at 04:59 PM.
    10-12-07 02:41 PM
  8. Titanbry77's Avatar
    What would that mean during the unlocking process? You think someone was trying to unlock it and messed it up? Under the Advanced Options < Sim Card < - It says "No Valid Sim Card"

    I know that for sure I have numerous valid sim cards.
    10-12-07 05:14 PM
  9. Berryman's Avatar
    Also worth checking that there is no damage, or any physical difference between the metal contact pins that read the chip on the SIM card of the Blackberry that does not recognize SIM cards, and compare closely with others.

    Re: last post, yes, could be a possibility, though would seem unlikely in this business environment.
    10-13-07 04:30 PM
  10. dr_roberts's Avatar
    I notice this an old article, but I'm new at BBs and I recently had a similar SIM problem. The Blackberry 8700c was given to me by a friend. It's AT&T, same as I have,so I removed the SIM from my old phone and it worked, but I forgot to copy my phone contacts to this SIM, so I put it back in my old phone, made the copy to SIM, put it back in the Blackberry, and got the exact same prompts as posted above. Invalid SIM card, Insert SIM card and SOS access only. The SIM works fine in my old phone, and even tried it in my daughter's cellphone. Still won't work in the BB. tried all the troubleshooting angles. Did a wipe and fresh Os install. Have tried reseating the SIM several times. Still no luck. Just worked the very first time. Must be a bad SIM slot. Too bad.
    12-27-07 03:31 PM
  11. njblackberry's Avatar
    NOT JOKING - are you sure the SIM card is oriented properly? That's not the message you would get from a locked BlackBerry.
    12-27-07 04:02 PM
  12. dr_roberts's Avatar
    Looks like the joke was on me. That took care of my problem. SIM card is recognized. Only problem I have now is a weak signal. I live on a groundfloor apt, but never had trouble with my old cell phone. Same with my daughter's. I'm sure I've followed everything through the setup, but I sure bozoed the SIM card. Thanks to njblackberry for setting me straight.
    12-27-07 07:20 PM
  13. dragonsc's Avatar
    If I joined the forum I could've told you, you put the sim card in the wrong way, I know cuz I had the same problem, after my friend smacked me in the head, and told me, I inserted the sim the wrong way.
    01-23-08 09:18 PM
  14. qdqswi's Avatar
    ive got the same problem.. and im sure the sim card is inserted right... :| it was working the day before yesterday...
    06-20-09 07:21 PM
  15. dayzee1307's Avatar
    You can correct this by going to opt> Mobile Network>Network Technology> Change this to global or 1XEV. (This is for people who do not actually have a sim card and are still receiving this message. )

    12-10-09 10:25 AM
  16. Eg2's Avatar
    ^^^ thanx bud that just fixed my buddy's tour
    08-15-10 04:06 PM
  17. dleugers's Avatar
    SOS is your phone saying is does not have service.

    Are you in and area with good service

    check Options folder > mobile network > on/automatic/global or 1XEV -- in US
    check Options folder > mobile network > on/automatic/global or gsm -- in Europe

    pull battery on phone - Reseat sim card

    call wireless provider
    11-05-10 11:38 AM