1. artman71's Avatar
    Hi everyone, I have an 8700c and I am having some problems with it of late. It keeps cutting out on me. I have done battery pulls, sim card pulls and sometimes it won't even restart then. I upgraded to os 4.5 and initially I suspected that was the issue. I downgraded to os 4.2 and it is still doing it. The battery is showing a near full charge. Is it a battery problem or does it sound like something more serious. Thanks!
    05-30-09 11:18 AM
  2. D2G's Avatar
    When you say "cutting out" do you mean a phone call cuts out/drops or do you mean the battery power cuts off?
    05-30-09 10:55 PM
  3. artman71's Avatar
    Power cuts out completely. I actually purchased a new battery today to see if the battery was the issue. I will update again in a couple days to let everyone know if that resolved the problem. Thanks!
    05-31-09 02:03 AM
  4. VIDGMER's Avatar
    my friend...Yes I was in your shoes.. I believe that battery is dead.. you have to buy new battery like I did..

    so let me know how turn it out asap..
    05-31-09 07:04 AM
  5. artman71's Avatar
    It has been almost 24hrs with the new battery and no problems with it since! I think this has resolved the issue.
    05-31-09 03:39 PM
  6. VIDGMER's Avatar
    It has been almost 24hrs with the new battery and no problems with it since! I think this has resolved the issue.
    Yes I hear you! thats great news! i am glad you resolved it.. enjoy with your 8700..
    06-01-09 03:03 AM
LINK TO POST COPIED TO CLIPBOARD