1. bmwmpower's Avatar
    My friend just bought a Cingular 8700c and is using with Cingular/ATT. It's blocking his number and its showing up as "unknown number" when he calls me on my phone. It has never done this before with his old phone. I am a Blackberry nut and I made sure all the settings are correct (Restrict my identity: NO and hide my number OFF) I have a Blackberry 8800 and his settings match mine, including security. We can't figure out for the life of us what is wrong. Maybe a setting on his sim card? Help appreciated!
    05-30-08 10:42 AM
  2. Hazysky's Avatar
    Has he entered his number onto the device?

    Options > advanced options > sim card, hit menu key select edit sim number and enter the number then exit to save. Then in smart dialing set show my number to yes.

    It may not fix the issue but worth a try.

    Also check that the country code has been added to smart dialing field.

    Posted from my CrackBerry at wapforums.crackberry.com
    05-30-08 11:07 AM
  3. bmwmpower's Avatar
    Yes all what you said is correct and set on his phone. Thanks though. Any other ideas?
    05-30-08 12:19 PM
  4. yogi's Avatar
    Check yo your cell phone provider. Because you may ask the to hide or not your phone number. Maybe it is hide. For me I prefer to hide my phone number when I make calls. I asked Bell Mobility (this my cell phone provider), and it's free to do it. If I want I can making not to be hide by simply a call to them and again, it's free.
    05-31-08 08:37 AM
LINK TO POST COPIED TO CLIPBOARD