1. JM19's Avatar
    I was getting an "SIM card error" on my BB so I went to the ATT store and got a new SIM card. Haven't gotten the SIM card error but noticed that now I'm unable to send or receive any MMS messages. So inwent back to the ATT store and they recommended trying yet a another new SIM card. Before leaving the store they tried sending a MMS message to my BB and I'm still having the same problem. When I get a MMS message it says, "can't receive message. try again later". So I go to try an receive message and I'm unable to do so. And if I try to compose an MMS message, I get the following, "no service record", and I can only save as a draft.

    The guy at the store said they really can't do much more at the store and recommended that I call the ATT tech support. So today I did. And let me just say that it was a total waste of time. I spent close to an hour and a half on the phone wit a tech person who didn't know what te he'll she was doing. She had me a few battery pulls. And asked for my BB's IMEI number, and had me on hold numberous times. Anyway, end result, she tried go give me some crap about how I didn't have MMS as a feature on my plan. Mind you, before getting the first new SIM card from the ATT store I was sending and receiving MMS messages with no problem. At this point I lost it, and asked for a supervisor/manager. They patched me through to someone else who somewhat seemed like they kinda new what they were talking about. But in the end still no success. This person recommended a complete handheld wipe and reinstall of the BB software, but mentioned how if that didn't work, how it could be my BB that's no good. I doubt this very much being that I was not having any problems before getting the new SIM.

    I don't know what else to try. I have no other problems sending or receiving text messages, emails, making/receiving calls, or going online. The only problem is with MMS. I hope somebody on here can help me out wit this issue. Thanks!

    Posted from my CrackBerry at wapforums.crackberry.com
    11-30-10 10:15 PM
  2. Fubaz's Avatar
    Sounds like a service book issue 100%.

    have you re registered your device?
    had them disable your BIS and then re add it?

    This is something you will have to work out with ATT a little more.
    11-30-10 10:18 PM
  3. JM19's Avatar
    I have sent the service books numerous times and also have re registered my BB and still nothing. ATT doesn't seem to know what they are doing. One thing I did notice, with the new BIS, there is now no option to enter a new device's PIN to register it. There is only a "detect new device" option. When I click on that, it tells me it can't detect my new device. Regardless though, my decide is registered with the ATT network and blackberry too.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-30-10 10:53 PM