1. ReverendC's Avatar
    My blackberry shows normally shows the persons name when some one calls. If I have a company name entered in the address book, it shows that instead. Any ideas how to make it show the persons name instead. I called T-mobile. I think they tried disabling content protection, but it didn't work. Any ideas?

    Also tried turning address book off under content protection as well. But I don't lock my BB so it shouldn't matter.
    Last edited by reverendc; 08-14-08 at 06:33 PM. Reason: added last line.
    08-14-08 05:52 PM
  2. AbeFrohman's Avatar
    Just a thought - is it a large company where phones go through a large phone bank? If so, the individual's number may not show - just the corporate main number & that's what shows on the caller ID.

    For example, my current business has prefixes of 834, but the phone trunk for outgoing calls always makes them show up as 568 prefix on the caller ID. Phone calls from the same phone don't show up the same way twice.
    08-14-08 06:03 PM
  3. ReverendC's Avatar
    The problem is with people in my address book. Anyone who is in my address book and has an entry in the "company name" field will show the company name instead of the persons name. If it's blank, it shows the persons name. If they're not in my addressbook, caller id works just like it would on any phone.
    Last edited by reverendc; 08-14-08 at 06:32 PM.
    08-14-08 06:25 PM
  4. AbeFrohman's Avatar
    Ah - gotcha. Sorry - I think I misread your original post. (trying to think if the caller ID problem has ever been an issue for me...)

    I'm looking at my settings. will post back if I have a brilliant idea.
    08-14-08 06:34 PM
  5. flgearhead's Avatar
    like instead of putting the company name in the right spot put it in front of the name like at&t pete or ge ryan this may be a quick simple fix if it is not a settings issue
    08-24-08 07:51 AM
LINK TO POST COPIED TO CLIPBOARD