1. lookitsangel's Avatar
    I wiped out my phone 2 weeks ago and put everything back together, but now my browser is gone, i cant find the email set-up icon and i tried using google maps but it said i have no data connection? pleaseee helppppp
    01-06-08 11:59 PM
  2. Bla1ze's Avatar
    You need to resend your service books to your device, log in to your carriers BIS site and send them to your self, if you dont know how, then contact your carrier, or you could just simply pull your battery out and see if the service books come back after a battery pull as they normally would.

    PS: Sorry for not linking you to your carriers BIS site, but you don't have your carrier listed in your profile.
    Last edited by Bla1ze; 01-07-08 at 12:27 AM.
    01-07-08 12:25 AM
  3. Pat8820's Avatar
    I have the same problem.
    Unable to get an answer regarding this issue from my carrier.
    RIM tech said my registration was fine.
    AIS carrier said they were working to solve it.
    Any news back "lookitsangel"?
    Where u able to solve the issue
    01-07-08 12:29 AM
  4. lookitsangel's Avatar
    I've pulled out my battery multiple times due to a messaging problem, sometimes i wont receive txt msgs for a day and wont know it, until i reset my phone and receive a million of them :/ and my phone shuts on and off at random times....i also tried to log on to my BIS and it wont let me! it says that my username is wrong ERRR
    01-07-08 06:06 PM
  5. lookitsangel's Avatar
    goodness, they finally let me log my BIS. I sent my service books to my phone and YAY it works! thanks Bla1ze!!!! ur the greatest... HEHE
    01-07-08 06:10 PM
LINK TO POST COPIED TO CLIPBOARD