1. LostInAsia's Avatar
    I have changed a setting and can not remember what I did. When I make a call my ID is not displayed and shows "Private Caller" to those that I call. They tend not to answer because they do not know it is me. I want to display my ID. Can anyone help?
    08-16-09 09:08 PM
  2. wandiweah's Avatar
    go to call log -> options -> general options and on "restrict my identity", switch it to "no"

    OR

    go to call log -> options -> general options and on "show my number", switch it to "yes"
    Last edited by wandiweah; 08-16-09 at 09:27 PM. Reason: left out information
    08-16-09 09:26 PM
  3. crandle13's Avatar
    Wandiweah's first response is correct. The 2nd "show my number" option only controls whether on not your number will show up on your dialing screen in case you don't know it.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-17-09 05:58 AM
  4. LostInAsia's Avatar
    Wandiweah and Crandle 13, Thanks a million. I have changed the setting and it works. Appreciate the help.
    08-17-09 02:56 PM
LINK TO POST COPIED TO CLIPBOARD