1. Peart's Avatar
    I got this blackberry 8700g secondhand. The darn thing won't turn on. I've tried the pull the battery thing, but still nothing. The only thing I do notice is that when I plug it in to charge, the LED notification light turns red for about 5 seconds and then it goes off. What the heck is wrong with this thing?
    02-19-08 01:05 PM
  2. Berryman's Avatar
    A battery that has totally lost all charge will take a long while before it has any sufficient power to power-on. If you have not already done so, you need to keep the device plugged into a wall charger for several hours until you can claim a "dead battery'/other problems
    02-19-08 01:36 PM
  3. Peart's Avatar
    I have. I charged it overnight. Twice. FWIW I also tried plugging in the blackberry without the battery and the same thing happens with the red LED notification light, comes on for 5 seconds then goes away.
    Last edited by Peart; 02-19-08 at 01:41 PM.
    02-19-08 01:37 PM
  4. Garz's Avatar
    Depending on how old the battery is, it may be shot. Maybe you can go to a store that sells the batteries to test and see if the battery is the problem or if its the BB itself.
    02-19-08 01:42 PM
  5. Zilch62's Avatar
    I just got a used 8700c and had the same problem. before you go buy a new battery check the charger out. I went to a cellphone accessory store and found that the charger they sent me with the phonne was not the original one that went with the 8700c. When I changed charger the battery did begin to charge. Check the battery and the charger.
    02-21-08 12:47 PM
  6. joey23's Avatar
    Mine is doing the same exact thing. I know the battery is good because I put it in my wifes BB and it powered up fine showing at least two battery bars.
    03-02-08 07:33 AM
  7. appleberry's Avatar
    I also just bought a 2nd hand 8700g, and had exactly the same problem. By looking at this thread, I checked things out by charging the phone via a USB charger (a mains plug with a standard USB female socket at the back, bought to charge my Archos), instead of the provided mains charger, and all was well. So it was the charger at fault and not the battery.
    03-08-08 12:32 PM
  8. krashner's Avatar
    so what would be the main thing for me to do/try
    01-25-10 03:04 PM
  9. rippedvanwinkle's Avatar
    Mine did the same thing. I have a couple of 8700c phones, and found that they will not charge with aftermarket chargers like iGo. They also did not charge from the PC. I plugged them into my 8330 Curve's charger, they have the same plug, and voila, both chargers stayed on. So, go get yourself a new original Curve 8330 charger, it worked for me. They charged right up in a couple of hours. Hope this helps.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-26-10 05:35 AM
  10. eby6114's Avatar
    took out the battery then plugged in the charger waited a few seconds then put in the battery, then it booted right up and told me the battery is dead, but this way I jump started the phone which had a battery so dead the smart charger built in would not work unless you fool it.
    10-20-10 12:59 AM
  11. mertonmarshall's Avatar
    My 8520 had the same problem sometimes they work and other times they don't try to get the original charger
    05-05-11 04:16 AM
  12. mandymeyden's Avatar
    If you have a dead battery, try this, heat your oven to 150, or equivalent, and put your battery in the oven for 10 minutes, no longer, remove and allow to cool down then place your battery back in your phone, wait for it to show the battery symbol with the yellow flash and then it will start reloading its self again and charging, it worked on mine and I cant guarantee it will work on everyones but it something to try before you go buying another one
    09-16-12 04:11 AM
  13. Chloe Coburn's Avatar
    my battery has been on charge for a while now,how long does it roughly take? will it take much longer? when i put my phone on charge it came up a blank battery and a red x on it.does this mean the battery's shot or what?
    01-22-13 01:09 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.