1. pinkdaisy226's Avatar
    Okay it's working now but it's been doing this for a while and I figured I'd ask about this just in case.

    I don't use my 8703e but today's my last day of my Pearl minute plan and I'm VERY low on minutes so I was using my 8703e minutes. Or trying to. Whenever I tried to dial a phone number, sometimes it would dial numbers and then sometimes it would dial letters. And no matter what I tried to do, it would only dial letters. For example... I was dialing 426... it would dial 42 and then F. I would hit back space and the 6 but it would type F.

    It would dial numbers from the address book just find so I decided I'd create a new address book entry. But I had the same problem. Some letters it would type as letters, others as numbers. Others it would type anything.

    For whatever reason, I just tested it out and it's fine now... but what was making it do this to begin with?
    06-02-08 02:01 PM
  2. sunkast's Avatar
    Keypad could be broke...
    06-02-08 02:17 PM
  3. insilentmovies's Avatar
    Yes, sounds like a keypad issue to me, too. If it can't be solved by a battery pull, then that's more than likely the issue.
    06-02-08 06:16 PM
LINK TO POST COPIED TO CLIPBOARD